Issue 115688

Summary: Crash when hitting Ctrl-Shft-F10 with focus on task pane
Product: Impress Reporter: cno
Component: codeAssignee: wolframgarten
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P2 CC: groucho266, issues, mdxonefour, oliver.brinzing, wolframgarten
Version: DEV300m93Keywords: regression
Target Milestone: 3.4.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description cno 2010-11-19 22:53:44 UTC
the task pane at the right can be (un-)docked via an entry in the the menu 'View'

analogue with the behaviour of the Navigator, I hit Ctrl-Shft-F10 to dock it
 > full crash
Comment 1 Oliver Brinzing 2010-11-21 12:38:28 UTC
confirming crash with oo 3.2/3.2.1 and oo 3.3rc5 (vista 32bit)
Comment 2 mdxonefour 2010-11-21 14:28:00 UTC
I can reproduce this issue in a good old OOo 3.1 on Windows already.
This is not a stopper for current 3.3 release.
Comment 3 mdxonefour 2010-11-21 16:15:16 UTC
md->af: I can reproduce this issue even in an OOo 3.0.0 final release on
Windows. I've sent crash reports from 3.0.0 on Windows and 3.3rc6 on MacOSX.
Comment 4 mdxonefour 2010-11-21 16:17:34 UTC
hold your breath guys, I can confirm that this did work in an OOo 2.4.2
adding keyword regression accordingly
Comment 5 wolframgarten 2010-11-22 09:40:49 UTC
Reproducible in DEV300_m93, OOO320_m18 (3.2.1) and 3.0 final. Ok in OOO330_m16.
Comment 6 Joost Andrae 2010-11-22 10:20:31 UTC
reproducible in OOO330m16 unxsoli4.pro (you just have to press Ctrl+Shift+F10
twice to get the crash)
Comment 7 wolframgarten 2010-11-22 10:30:39 UTC
I depends... I had an impress open where I tested this shortcut with the
navigator. And then it works with the TaskPane as well. Having a fresh impress
opened (without testing the navigator) CTRL-SHIFT-F10 crashes in OOO330_m16, too.
Comment 8 cno 2010-11-22 11:15:47 UTC
Sorry that I did not check it in previous versions of OOo.
I expect that it is rather unlikely that people are affected by this bug, so had
not the idea to propose it as showstopper.
Comment 9 groucho266 2010-11-22 13:28:11 UTC
The crash is caused by sd::Window not correctly forwarding the result of key
event processing (in sd::Window::Notify).

This leads to windows being deleted while VCL is still delivering events to them.
Comment 10 groucho266 2011-02-10 08:18:39 UTC
Fixed by correctly forwarding the result of ::Window::Notify().
Comment 11 groucho266 2011-03-23 08:13:59 UTC
@wg: Please verify.
Comment 12 wolframgarten 2011-03-30 08:20:11 UTC
Verified in CWS.