Issue 115698

Summary: assertion: SVRect() without Width or Height
Product: Writer Reporter: 400guy <tenger>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, rb.henschel
Version: DEV300m92   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
file which provokes the assertion none

Description 400guy 2010-11-20 20:10:00 UTC
I am running a non-product build of DEV300_m92.  


To provoke the assertion ...

(*) From Welcome Center, click Text Document.  Program opens window
    Untitled 1.

(*) From document Untitled 1, take menu option File > Open.  Program
    displays Open dialog.

(*) Navigate to soon-to-be-attached file semantic_web.html, and click
    Open.  Program displays Debug Output ...

        Error: Assertion failed
        ==================
        FILE      :  ../../../inc/swrect.hxx at line 309
        ERROR :  "SVRect() without Width or Height"
        Abort ? (Yes=abort / No=ignore / Cancel=core dump)


Note, that the conditions for raising the assertion are somewhat
--ahem--flaky.

(*) If you close Untitled 1, and then use File > Open from the Welcome
    Center, the program does not raise the assertion.

(*) If you continue through opening and closing the document from the
    menu in Untitled 1, some openings raise the assertion more times
    than other openings.

(*) Yikes, it is worse than that!  I have one file which raises the
    assertion of issue 114579 "assertion: sentence indices out of
    range" before the assertion I am documenting here.  If I leave the
    first dialog box open for several seconds, I hear two or three
    more beeps but the program opens the file without displaying any
    more assertions, and at least once the program raised no
    assertions the next time I opened the file.  Is the dependence on
    timing grounds for raising a separate issue?


In a comment to issue 91658, mst mentioned this assertion and said he
hopes that someone has filed an issue.  I do not see exactly that
issue, so am filing this one.  However, along the way, I did find
related issues.

(*) 91658 "ERROR : "No browse width available", as I mentioned above.
    It is now CLOSED FIXED, cws sw33bf04, integrated in DEV300_m82.

(*) Issue 44083 "ERROR SVRect() ohne Width oder Height", NEW.  I am
    guessing that it is different because it arose in Base from menu
    option Insert > Report.  Please feel free to mark this issue a DUP
    if you think that is more helpful.

(*) The assertion appears 25 times within the log information in issue
    111190, status NEW.

(*) The assertion appears once within the log information in issue
    111197, STATUS NEW.

(*) I have notes from the time of DEV300_m88 suggesting that this
    assertion is related to issue 110234 'ERROR :
    "<SwNoTxtNode::SetObjTitle(..)> - missing <SdrObject> instance'.
    Alas, I did not write down why I thought they had anything to do
    with each other.
Comment 1 400guy 2010-11-20 20:11:44 UTC
Created attachment 75077 [details]
file which provokes the assertion
Comment 2 Regina Henschel 2010-12-07 17:18:55 UTC
I get the same assertion, when I drag the scroll bar slider down or use the down
button to scroll down, a short distance before it reaches the lower end.
Is it the same reason or should I write a new issue?

Error: Assertion failed
==================
FILE      :  ../../../inc\swrect.hxx at line 309
ERROR :  "SVRect() without Width or Height"