Issue 116123

Summary: Updating PDF Import Extension via extension manager results in unusable extension.
Product: Draw Reporter: Dotan Cohen <>
Component: codeAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: a.finch, inletub, issues, wilbur
Version: OOo 3.2.1   
Target Milestone: ---   
Hardware: Unknown   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Dotan Cohen 2010-12-14 13:24:40 UTC
Up to version 1.0.1, the [Sun|Oracle] PDF Import Extension would open PDF files
in Draw, and hybrid ODT-PDF files in Writer. In version 1.0.4 both file types
open in Writer with the PDF header, not the content.

Steps to reproduce: Install PDF Import Extension 1.0.4 in 3.x.
Open OOo, click File->Open and choose a PDF file (either hybrid or regular).

What happens:
This text is displayed in Writer:
2 0 obj
<</Length 3 0 R/Filter/FlateDecode>>
x�¥�]k$ַ#†ןחW4ה־ Q}W5ˆ�ׁH‚#|a"נֵג#�»kl#%�#עקSUחtקTקי~�#

What was expected to happen:
The user expects the PDF to open for editing.
Comment 1 Dotan Cohen 2010-12-14 13:25:51 UTC
From the extension's homepage it seems that many people are suffering this
issue, both on Linux and Windows:
Comment 2 kaplanlior 2010-12-14 22:06:08 UTC
Did you restart your after installing this extension. The PDF headers
your mention is typical when the extension isn't present.
Comment 3 wolframgarten 2010-12-15 09:14:08 UTC
No problem with version 1.0.4 on OOo 330_m18. pdf opens fine.
Comment 4 Dotan Cohen 2010-12-15 19:20:46 UTC
> Did you restart your after installing
> this extension.

Yes, of course. The OOo Quickstart icon is also disabled, I should add. Even
after a system reset to be sure, I still have the issue. I should mention that
this was an in-place upgrade from version 1.0.1: I pressed "Check for updates"
from within the Extension Manager
Comment 5 Dotan Cohen 2010-12-15 19:32:30 UTC
It seems the "in place upgrade" is broken. When I remove the extension and
reinstall from the file downloaded in my web browser, the PDF open feature works
as expected. When I reinstall 1.0.1, then "in place upgrade" to 1.0.4, the
feature is broken as described in the OP.

I am changing the bug title to reflect this.
Comment 6 philipp.lohmann 2011-01-06 17:05:00 UTC
I'll try to reproduce this.
Comment 7 philipp.lohmann 2011-01-31 16:31:30 UTC
I have not been able to reproduce this problem on Mac, Windows or Linux. Any
hints on what I might be doing differently ? I installed OOo, installed 1.0.1,
loaded a PDF, installed 1.0.4 (either through online update or by "add..."),
loaded a PDF again.

Worked fine for me, so there probably is something else.

@wg: please proceed
Comment 8 jimnivens 2011-01-31 17:19:30 UTC
I just downloaded v 1.0.4 with no previous installations of the add-on.

After installing and rebooting my computer, I get this same problem.

I select File-Open, select a PDF file, then it shows me the ASCII filter pop-up.

Then when it imports the file, it's just the PDF header with a bunch of random 

{Windows Vista with OO v 3.2.1}
Comment 9 wolframgarten 2011-02-01 14:31:33 UTC
Please proceed, easier said then done... ;-) Could not reproduce , too. Update
to 1.0.4 on Linux works without problems.
Comment 10 armstrong_almeida 2011-02-14 02:40:19 UTC
I'm having this issues as well in OS X.  I just downloaded Oo 3.3 and the 1.0.4
version for Snow Leopard.  I tried running it through pdftk with no luck.
Comment 11 stoopsolo 2011-02-18 16:42:16 UTC
I am having exactly the same problem on Ubuntu 10.10. Downloaded and installed 
the filter (1.0.4) and it is showing up nicely in the extensions manager. But 
when I try to open a PDF from Draw (my OO is version I also get the ASCI 
window and then the file opens in Writer showing a bunch of gibberish. (I also 
rebooted in between)

I have never tried the filter before so have no previous experience with it. It 
would be nice if it worked though. Are there any supplementary packages/add-ons 
that are necessary for this filter to work?
Comment 12 inletub 2011-03-23 11:40:42 UTC
LibreOffice 3.3.1 
OOO330m19 (Build:8)
tag libreoffice-, Debian package 1:3.3.1-1
PDF Import Extension 1.0.4

I got the same problem while trying to open any not hybrid PDF file (didn't have hybrid yet).

So I did the following :

1/ Deactivate the extension
2/ Reactivate it
3/ Restart LibreOffice
4/ Open a new odt document and writing in some "lorem ipsum"
5/ 'Export as PDF' in 'File' menu and let all the default options but just added "Create hybrid file"
6/ Then I tryied to open this newly exported file and the extension has worked
7/ So I re do the same from 4 to 5 without the hybrid option and get positive result again (opening in draw)

And now I can open any PDF file ( with draw if not hybrid) including pdf files that I couldn't open before (headers only problems)

I hope this will help
Comment 13 wilbur 2011-03-29 01:19:48 UTC
I followed the same process as described in comment #12, but this did NOT work for me.  

Using Ubuntu 10.10 3.2.1 
OOO320m19 (Build:9505)
ooo-build, Ubuntu package 1:3.2.1-7ubuntu1.1

PDF Import Extension 1.0.4

Why isn't there an import option?

Also how can you define what OO application will be associated with fle extensions.  

Comment 14 ajfinch 2011-03-29 21:44:37 UTC
Solution in comment 12 worked for me too. (Ubuntu 10.10)
Comment 15 wilbur 2011-03-29 21:55:58 UTC
New comments gave me hope.  I followed the directions in comment #12 exactly again, and it started working!  Great, thanks.
Comment 16 harold_bien 2011-04-09 23:28:16 UTC
On Windows 7 x64 with FireFox 3.6.16, attempting to launch the "odx" extension results in an invalid installation with an entry of "oracle-pdf-import" extension that you can not remove and is non-functional. Saving the "odx" file and then launching it from Windows Explorer gives the proper functionality.

If successful, you should get a message regarding license agreement (I did not get such a notice the first time around). I was then able to open up PDF files properly.
Comment 17 Marcus 2017-05-20 11:33:19 UTC
Reset assigne to the default "".