Issue 116460

Summary: Calc takes roughly 4 minutes on a high end CPU to open a particular XLS document
Product: Calc Reporter: xlsbug <m8r-lp5st9>
Component: open-importAssignee: oc
Status: CLOSED FIXED QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: daniel.rentz, issues, mdxonefour
Version: OOO330m9   
Target Milestone: 3.4.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
A problematic XLS file (packed with XZ, use 7zip under windows to decompress it)
none
test document with autofilters none

Description xlsbug 2011-01-14 10:32:02 UTC
My local computer store distributes XLS price list which weighs 2.83 MB 
(2,967,552 Bytes).

Calc 3.3 rc9 takes roughly 4 minutes to open it on a high end PC (Intel Core 
i920).
Comment 1 xlsbug 2011-01-14 10:34:01 UTC
Created attachment 75562 [details]
A problematic XLS file (packed with XZ, use 7zip under windows to decompress it)
Comment 2 Marcus 2011-01-14 11:28:47 UTC
due to the rules not a P1 issue
Comment 3 niklas.nebel 2011-03-17 17:32:26 UTC
confirmed.
Comment 4 daniel.rentz 2011-03-17 17:46:56 UTC
patch reviewed
Comment 5 niklas.nebel 2011-03-18 09:02:37 UTC
Fixed in CWS dr80.
This affects loading of the file as xls or xlsx, and selecting outline levels in the file.
Comment 6 daniel.rentz 2011-03-21 11:08:28 UTC
Loading XLSX with auto filters are not filtered anymore.
Comment 7 daniel.rentz 2011-03-21 11:09:23 UTC
Created attachment 76158 [details]
test document with autofilters
Comment 8 daniel.rentz 2011-03-30 13:35:22 UTC
cannot reproduce anymore, back to fixed
Comment 9 niklas.nebel 2011-03-30 15:28:23 UTC
reassigning to QA for verification
Comment 10 oc 2011-04-05 10:43:58 UTC
verified in internal build cws_dr80