Issue 116639

Summary: print dialog in German build is much too wide & has wrong resources
Product: Internationalization Reporter: jmpoo <jmpoo-bugz>
Component: uiAssignee: ivo.hinkelmann
Status: RESOLVED FIXED QA Contact: issues@l10n <issues>
Severity: Trivial    
Priority: P3 CC: boogzilla, gemastorakis, helge.delfs, issues, jdaniel.alvaro, pescetti, rjaaskel, thorsten.ziehm, torokhov-s-a
Version: DEV300m106Keywords: regression
Target Milestone: 3.4.1   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Screenshot Writer
none
Screenshot Impress
none
Screenshot of print dialogue under Catalan l10n none

Description jmpoo 2011-01-26 16:43:32 UTC
Open "File - Print" and you will see ...
same in Calc
works in Draw and Impress
Comment 1 eric.savary 2011-01-26 18:13:12 UTC
Cannot reproduce. Nothing special.
please report issues correctly: add screenshots, explain what you see...
Comment 2 jmpoo 2011-01-27 07:57:07 UTC
Sorry, here are more details and two screenshots:

OOo300m98, engl. with german lang.-pack, default options

After your hint I removed the german language pack and it works as expected in
english version.


Comment 3 jmpoo 2011-01-27 08:01:13 UTC
Created attachment 75675 [details]
Screenshot Writer
Comment 4 jmpoo 2011-01-27 08:02:13 UTC
Created attachment 75676 [details]
Screenshot Impress
Comment 5 thomas.lange 2011-01-27 08:06:06 UTC
Please add the document you were trying to print. Maybe it is related to that.
Comment 6 jmpoo 2011-01-27 08:59:33 UTC
No special document. 

I open a new writer document, insert dummy text from writer AutoText (in german
version I type "bt" and press "F3") and open print dialog. Same behavior if I
open a new writer doc without inserting dummy text and open print dialog.

Same procedure in Calc: I open a new calc spreadsheet, type 5 into any cell to
get a printable spreadsheet and open print dialog. 

Same procedure in Draw or Impess: I open a new document and open print dialog
but there it works as expected.
Comment 7 philipp.lohmann 2011-01-27 09:56:11 UTC
Actually this comes from changed UI strings in writer (and calc and math I
believe); until there is new localization the wrong strings will be taken for
the controls (since the list of strings that makes up the localization for this
dialog has changed and they are now in a different order) making the controls
grow to fit the text. This will be repaired when the stringlist gets translated.
Comment 8 michael.ruess 2011-01-27 11:09:52 UTC
Closed; as the screenshot shows, the UI resources are mixed up. The updated
language pack must be used.
Comment 9 michael.ruess 2011-02-02 14:41:32 UTC
Reopening issue, problem occurs in German language pack.
Comment 10 michael.ruess 2011-02-02 15:06:38 UTC
MRU->PL: the print dialog looks as shown on screenshot. There seem to be wrong
resources on the "Seitenlayout" tab page. IHI claims himself innocent and isn't
able to fix this with issue 116651.
Comment 11 philipp.lohmann 2011-02-08 14:26:28 UTC
Resetting target accroding to new task handling scheme announced here:

http://blogs.sun.com/ratte/entry/some_changes_for_the_openoffice
Comment 12 philipp.lohmann 2011-02-10 10:34:19 UTC
Whatever ivo does do or not, he does not translate the string list in the writer
resource that causes this problem. This has to happen to solve the problem. It
will happen when translation for 3.4 gets integrated. And that's that.
Comment 13 philipp.lohmann 2011-02-10 10:34:37 UTC
closing
Comment 14 thorsten.ziehm 2011-04-07 07:36:24 UTC
I reopen this issue, because it is important to see for the L10N teams, that they have to do some work, to fix this issue. By the way, Ivo could you check, if there is all correct with the strings lists for the printer dialog from L10N perspective, please. Therefore I set the issue to you.

I also set keyword 'regression' for this issue. This should highlight, that this is an important broken functionality, which have to be fixed for OOo 3.4.

More details about the effects of this problem can be found in a report by Serg Bormant  : 
http://openoffice.org/projects/l10n/lists/dev/archive/2011-04/message/14

How the L10N teams can fix this issue :
Rafaella Braconi wrote in http://openoffice.org/projects/l10n/lists/dev/archive/2011-04/message/12 :
"Just to  be more specific. In order to see this issue fixed, following files/strings need to be translated:
vcl/source/src.po
sw/source/ui/config.po ID STR_PRINTOPTUI
sc/source/ui/src.po ID SCSTR_PRINT_OPTIONS
starmath/source.po ID RID_PRINTUIOPTIONS
I encourage all language teams to make sure this files are translated to guarantee functionality."
Comment 15 thorsten.ziehm 2011-04-07 12:43:18 UTC
*** Issue 117738 has been marked as a duplicate of this issue. ***
Comment 16 jmpoo 2011-04-07 13:01:21 UTC
The behavior which I described above and which is shown at the screenshots is not the same as issue 117738 and not present in Dev300m106.
The width of the dialog is ok now.

But now there are new faults as I described in issue 117738.
Comment 17 thorsten.ziehm 2011-04-08 07:13:29 UTC
*** Issue 117761 has been marked as a duplicate of this issue. ***
Comment 18 Marcus 2011-04-15 09:02:08 UTC
*** Issue 117607 has been marked as a duplicate of this issue. ***
Comment 19 Marcus 2011-04-15 09:03:46 UTC
*** Issue 117591 has been marked as a duplicate of this issue. ***
Comment 20 RCat 2011-10-14 19:54:27 UTC
I can confirm the same issue occurs in the Catalan localisation of LibreOffice 3.4.2 [OOO340m1 (Build:1206)]
Comment 21 RCat 2011-10-14 19:58:34 UTC
Created attachment 76890 [details]
Screenshot of print dialogue under Catalan l10n

Screenshot showing the problem (half the print options are missing). Incidentally, I am not sure about the "Trivial" importance given to this bug, as it is a serious showstopper for anyone using an affected localisation.
Comment 22 jmpoo 2012-03-22 16:02:59 UTC
Works for me in AOO 3.4
I've tested at last in Rev 130 3653

So status should be set to "Fixed" and it is no longer a blocker for 3.4  :-)
Comment 23 sorath 2012-03-24 10:53:29 UTC
(In reply to comment #21)
> Created attachment 76890 [details]
> Screenshot of print dialogue under Catalan l10n
> 
> Screenshot showing the problem (half the print options are missing).
> Incidentally, I am not sure about the "Trivial" importance given to this bug,
> as it is a serious showstopper for anyone using an affected localisation.

I also confirm it for Finnish lang pack.


As for missing of print options I created issue:

https://issues.apache.org/ooo/show_bug.cgi?id=119120

Please comfirm it on that page.
Comment 24 Marcus 2012-03-25 22:30:15 UTC
changed status regarding comment #22
Comment 25 jmpoo 2012-03-26 08:34:33 UTC
Hi sorath and RCat,
please have a look at my attached sreenshots, which shows what "much too wide" means.

The bug you describe and wich is shown on your screenshot are missing tab pane and missing print options as described in bug 117738.
Comment 26 Risto Jääskeläinen 2012-04-16 11:58:24 UTC
It seems that for unknown reason there is in file sw/source/ui/config.po lot of translated lines so that tooltip text are inserted as every second line.  Result is that this long tooltip text are shown in print dialog/window and make its extreme broad /wide.  This I can see in Finnish Apache Pootle.  But I can only make "Ehdota" (Suggestion?) as "nobody" because Apache do not give me rights to make corrections in Pootle. Not even to my own translations. And I even don't know if there is anybody who understand Finnish and have those rights.

I must say that not even Oracle have this kind of burocrazy.

Greetings
Risto
Comment 27 DanielAlvaro 2013-03-14 00:36:59 UTC
Closed, I didn't find any problem. 

Regards