Issue 117283

Summary: New functions not covered by Excelfilter
Product: Calc Reporter: oc
Component: open-importAssignee: oc
Status: CLOSED FIXED QA Contact: issues@sc <issues>
Severity: Normal    
Priority: P3 CC: awf.aoo, issues, ooo
Version: DEV300m100   
Target Milestone: 4.0.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
XLSX import test
none
XLSB import test
none
XLS import test (generated by Excel 2007)
none
roundtrip test for XOR none

Description oc 2011-03-08 12:46:11 UTC
With cws calcishmakkica five new function (countifs, sumifs, averageif, averageifs and xor) will be implemented to the calc core. These functions are not covered by the Excelfilter
Comment 1 daniel.rentz 2011-03-09 09:58:11 UTC
1) Functions COUNTIFS, SUMIFS, AVERAGEIF, AVERAGEIFS:

Implemented import from OOXML (*.xlsx, *.xlsm) and BIFF12 (*.xlsb) files. Functions are not supported in Excel 2003 and earlier, but Excel 2007 writes them as external functions with prefix "_xlfn." to BIFF8 (Excel 97-2003 *.xls) files. Implemented import of these functions from BIFF8 too. Implemented export to BIFF8 as external functions the same way Excel does.

2) Function XOR

This function is not supported by Excel. The BIFF8 export filter writes it as special external function "_xlfnodf.XOR", and the BIFF8 import filter restores it to XOR.
Comment 2 daniel.rentz 2011-03-09 11:06:41 UTC
Created attachment 76055 [details]
XLSX import test
Comment 3 daniel.rentz 2011-03-09 11:07:13 UTC
Created attachment 76056 [details]
XLSB import test
Comment 4 daniel.rentz 2011-03-09 11:07:47 UTC
Created attachment 76057 [details]
XLS import test (generated by Excel 2007)
Comment 5 daniel.rentz 2011-03-09 11:08:23 UTC
Created attachment 76058 [details]
roundtrip test for XOR
Comment 6 daniel.rentz 2011-03-09 11:08:43 UTC
back to QA
Comment 7 oc 2011-03-10 08:38:07 UTC
verified in internal build cws_calcismakkica
Comment 8 ooo 2011-03-18 15:59:40 UTC
*** Issue 117000 has been marked as a duplicate of this issue. ***
Comment 9 Oliver-Rainer Wittmann 2012-06-13 12:24:59 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.
Comment 10 Andre 2014-02-25 10:34:36 UTC
Bug 122856 is a regression of the fixes for this issue.