Issue 117600

Summary: Repaint problem with frames wrapping "in background"
Product: Writer Reporter: Regina Henschel <rb.henschel>
Component: viewingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Normal    
Priority: P3 CC: eric.savary, issues
Version: DEV300m104   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Example for wrong view of background drawings in two page view none

Description Regina Henschel 2011-03-29 19:25:50 UTC
Open attached document. It has got some rectangles, which lay in the background behind the text, to emphasize the text.
Set the view to two pages.
Reduce the zoom, so that you start to see 2 pages.
Notice, that the rectangles now cover the text.

This does not happen in OOo3.3, so it is a regression.
Comment 1 Regina Henschel 2011-03-29 19:28:12 UTC
Created attachment 76220 [details]
Example for wrong view of background drawings in two page view
Comment 2 Regina Henschel 2011-03-29 19:50:24 UTC
Ok, no regression. It is wrong in OOo3.3 or OOo3.2 too.

It seems to be a refresh problem. If you scroll up and down the missing text is shown. But text disappears again, when you change the zoom, as long as at least a little bit from the second page is shown.

You can test it in 'Full Screen' view too, where you can use larger zoom.
Comment 3 eric.savary 2011-04-11 19:41:21 UTC
@OD: as described. When playing with the zoom you will find a factor where the text disappears behind the frame which are anchored in background. Then, scrolling up and down, the text will re-appear piece after piece.
Repaint problem.
Comment 4 eric.savary 2011-04-11 19:43:09 UTC
...sorry: not "anchored" but "wrapping" in background.
Comment 5 Oliver-Rainer Wittmann 2012-06-13 12:17:31 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.
Comment 6 Marcus 2017-05-20 11:35:13 UTC
Reset assigne to the default "issues@openoffice.apache.org".