Issue 117713

Summary: Several assertions about fallbacks for field unit
Product: General Reporter: Mathias_Bauer
Component: codeAssignee: Mathias_Bauer
Status: CLOSED FIXED QA Contact: issues@framework <issues>
Severity: Normal    
Priority: P3 CC: issues, tenger
Version: DEV300m103Keywords: regression
Target Milestone: ---   
Hardware: PC   
OS: Windows NT   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
suggested patch none

Description Mathias_Bauer 2011-04-06 07:11:30 UTC
found in many CAT0 tests in w_updt.bas, e.g. tViewToolbars
Comment 1 Mathias_Bauer 2011-04-06 07:53:03 UTC
Created attachment 76285 [details]
suggested patch
Comment 2 Mathias_Bauer 2011-04-06 08:16:39 UTC
Some time ago several assertions have been added that bail out when a field unit is retrieved from an ItemSet or SfxModule that don't know anything about it. But obviously this is a quite common case and falling back to the default INCH is fine. Thus I removed these assertions again.
Comment 3 Mathias_Bauer 2011-04-06 08:32:14 UTC
*** Issue 110601 has been marked as a duplicate of this issue. ***
Comment 4 Oliver-Rainer Wittmann 2012-06-13 12:23:03 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.