Issue 118012

Summary: OpenOffice.org crashes when deleting several rows conditionally formated
Product: Calc Reporter: paulo.m.costa
Component: formattingAssignee: Oliver-Rainer Wittmann <orw>
Status: CLOSED FIXED QA Contact: issues@sc <issues>
Severity: Major    
Priority: P2 CC: hdu, issues, jsc, lilinyi921734, oliver.brinzing, orw
Version: OOo 3.3 RC10Keywords: crash
Target Milestone: ---Flags: jsc: 3.4_release_blocker+
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
spreadsheet with condinional format cells on sheet 3 none

Description paulo.m.costa 2011-05-13 13:23:48 UTC
Created attachment 76507 [details]
spreadsheet with condinional format cells on sheet 3

On sheet 3 of attaches spreadsheet several cells are conditionally formated.
If I select several rows (with control-left click) and try to delete them , OpenOffice.org crashes.(processed killed)
Comment 1 Oliver Brinzing 2011-05-14 15:26:40 UTC
confirming, deleting several rows from sheet "TeamCollab" will crash oo3.4beta1.
Comment 2 hdu@apache.org 2012-02-03 10:18:56 UTC
Not reproducible on recent builds of Apache OpenOffice.
Please confirm by retesting your scenario with a build from https://cwiki.apache.org/confluence/x/f8KoAQ
Comment 3 Oliver Brinzing 2012-02-23 08:33:08 UTC
confirming crash with rev1291124 (vista 32bit)

steps to reproduce:

- open attached file
- select rows 15-37
- right click -> delete rows
- aoo will crash
Comment 4 Olaf Felka 2012-02-23 09:08:10 UTC
As it is a crash we should raise the prio.
Comment 5 jsc 2012-03-01 13:25:32 UTC
I can't reproduce this issue as well on Wondows 7 and MacOS 10.7

Can anybody confirm this on Vista with the latest AOO dev snapshot?
Comment 6 jsc 2012-03-01 13:45:40 UTC
correction, I can confirm this issue, crash for me as well
Comment 7 Oliver-Rainer Wittmann 2012-03-01 15:56:16 UTC
Workaround to avoid the crash:
- Before deleting the rows first select "Show" from the context menu.
The following "Delete Rows" works fine afterwards.

Please confirm this workaround.
Comment 8 Oliver Brinzing 2012-03-01 17:02:05 UTC
confirming workaround, deleting visible rows does not crash aoo.
Comment 9 Oliver-Rainer Wittmann 2012-03-06 08:30:32 UTC
I have found the root cause of the crash.
I am working now on a fix.
Comment 10 Oliver-Rainer Wittmann 2012-03-07 09:51:22 UTC
fixed the crash with revision 1297916

fix can be verified in next developer snapshot.
Comment 11 Li Lin Yi 2012-06-12 07:31:16 UTC
Verified on AOO3.4, rev 1327774.