Issue 118218

Summary: vlookup matrix formula is buggy
Product: Calc Reporter: Oliver Brinzing <oliver.brinzing>
Component: codeAssignee: spreadsheet <spreadsheet>
Status: CLOSED DUPLICATE QA Contact: issues@sc <issues>
Severity: Normal    
Priority: P2 CC: issues, oliver.brinzing
Version: 3.4.0 Beta (OOo)Keywords: regression
Target Milestone: ---Flags: oliver.brinzing: 3.4_release_blocker?
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
test_matrix_vlookup
none
test_performance_matrix none

Description Oliver Brinzing 2011-06-27 13:27:44 UTC
Created attachment 76639 [details]
test_matrix_vlookup

open attached spreadsheet with oo 3.3 and
compare results in column E and F.

With oo 3.4beta column "E" shows only Value "10" 
for all rows.

regression
Comment 1 Oliver Brinzing 2011-06-27 16:46:15 UTC
Created attachment 76644 [details]
test_performance_matrix
Comment 2 Oliver Brinzing 2011-06-27 16:48:22 UTC
adding a second example to show that loading a spreadsheet
with oo34beta will take a long time compared to oo 3.3.
changing a value in column "C" takes a long time too ...
Comment 3 niklas.nebel 2011-07-04 11:29:19 UTC
Same as issue 118125 (the "array formula" case mentioned there).

*** This issue has been marked as a duplicate of issue 118125 ***
Comment 4 Oliver-Rainer Wittmann 2012-06-13 12:27:48 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.