Issue 118355

Summary: cli assemblies are not able to work with .Net Framework 4.0
Product: App Dev Reporter: saneeasayyed
Component: apiAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Normal    
Priority: P3 CC: issues, saneeasayyed
Version: 3.3.0 or older (OOo)Keywords: ms_interoperability
Target Milestone: ---   
Hardware: PC   
OS: Windows 7   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description saneeasayyed 2011-07-29 10:03:41 UTC
1) We have developed an OXT package which uses the cli_XXXX.dll assemblies given by open office.
2) The add-in is working fine when we were using .Net Framework 3.5.
3) We tried to upgrade the framework from 3.5 to framework 4.0. We had to do "regasm" "cli_oootypes.dll" (i.e. register the assembly to COM) after that we were able to compile the code successfully. 
4) Now, when we try to run it we get an run time exception 
"FileLoadException: Mixed mode assembly is built against version 'v2.0.50727' of the runtime and cannot be loaded in the 4.0 runtime without additional configuration information".
5)we also tried to put  following configuration to soffice.exe.config, swriter.exe.config but did not get any success.

<startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.0"/>
</startup>

<startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v2.0.50727"/>
                <supportedRuntime version="v3.5"/>
                <supportedRuntime version="v4.0"/>
</startup>
6) We even tried registering the remaining assemblies to COM but still no use.
7) Can we get cli's that work with .Net Framework 4.0
Comment 1 Marcus 2012-03-03 12:14:56 UTC
this issue is no P1
Comment 2 Oliver-Rainer Wittmann 2012-06-13 12:18:49 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.