Issue 118505

Summary: Remove MN_OLE_OBJECT menu item from Draw/Impress contextmenu
Product: Draw Reporter: Ariel Constenla-Haile <arielch>
Component: uiAssignee: Ariel Constenla-Haile <arielch>
Status: CLOSED FIXED QA Contact:
Severity: Normal    
Priority: P5 (lowest) CC: issues, pfg, wolframgarten
Version: recent-trunk   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: PATCH Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
MN_OLE_OBJECT popup menu empty, as a simple menu item. OLE verbs at the bottom of the context menu
none
Proposed patch none

Description Ariel Constenla-Haile 2011-10-13 12:55:55 UTC
Created attachment 76882 [details]
MN_OLE_OBJECT popup menu empty, as a simple menu item. OLE verbs at the bottom of the context menu

Draw/Impress add a menu item MN_OLE_OBJECT to the OLE object context menu.
This menu item is supposed to hold a popupmenu to be filled at runtime by an sfx-based popupmenu controller, implemented in SfxObjectVerbsControl, but this controller is never regsitered at the sfx shell; instead, the OLE verbs are filled at runtime just like in the oder applications, Writer and Calc, and appened at the bottom of the context menu.

THe manu item should be removed.
Comment 1 Ariel Constenla-Haile 2011-10-13 13:09:44 UTC
Created attachment 76883 [details]
Proposed patch

Proposed patch, taken from CWS contextmenu1 http://hg.services.openoffice.org/cws/contextmenu1/rev/74545a202153
Comment 2 Pedro Giffuni 2011-10-13 15:40:44 UTC
Committed in revision 1182915.

Thanks!!
Comment 3 Ariel Constenla-Haile 2011-10-13 21:27:55 UTC
Resolved as fixed.
Comment 4 Ariel Constenla-Haile 2011-10-14 00:21:37 UTC
*** Issue 78703 has been marked as a duplicate of this issue. ***
Comment 5 Ariel Constenla-Haile 2011-10-14 00:24:54 UTC
*** Issue 45851 has been marked as a duplicate of this issue. ***
Comment 6 Oliver-Rainer Wittmann 2012-06-13 12:31:42 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.