Issue 118824

Summary: Object position changes for printing or export-as-pdf
Product: Draw Reporter: DrC <drcowsley>
Component: printingAssignee: Armin Le Grand <Armin.Le.Grand>
Status: CLOSED FIXED QA Contact:
Severity: Major    
Priority: P5 (lowest) CC: Armin.Le.Grand, hanya.runo, issues
Version: version58Flags: drcowsley: 3.4_release_blocker?
Target Milestone: ---   
Hardware: PC   
OS: Windows 7   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
archive zip with file, pdf export and screenshot of print preview none

Description DrC 2012-01-22 19:26:41 UTC
Created attachment 77160 [details]
archive zip with file, pdf export and screenshot of print preview

Reminiscent of bug 63608.

The attached document has four border elements, three of which are no problem but the fourth insists on relocating when printed (visible in print preview) or when exported as pdf.  No workaround has been found.

Preview in web browser does not show the problem

OOO330.m20 (Build 9567)

Earlier versions I can test with do not show the problem - but because there is no print preview and no printer on these systems I could only look at the pdf export:

Build 9505 on Ubuntu seems OK (pdf export)
Build 9483 on Win XP seems OK (pdf export)
Comment 1 DrC 2012-01-22 19:32:25 UTC
Oops - apologies - summary  now says 3.4 blocker.  I left the default because your version drop-down list only had 3.3RC versions, and this is current release.

See text for the actual build reference.  If it is not a 3.4 blocker, apologies.

DrC
Comment 2 hanya 2012-01-23 10:16:52 UTC
This could be reproduced with OOo 3.3.0m20 on Windows XP. This was not happen with OOo 3.3.0m20 on Linux.
I want to make this problem more clear. This happened on vertically flipped image. But both horizontally flipped and flipped twice vertically and horizontally flipped images are looks good.

So, workaround is to flip the image with the program which process pictures. Or convert the document to PDF with the office which working other kind of operating system.
Comment 3 hanya 2012-01-25 05:35:36 UTC
The preview of ODF file is also wrong. And a presentation having vertically flipped image has the same problem in presentation mode on Windows environment.
But OOo 3.2.1 does not have this problem.
Comment 4 Armin Le Grand 2012-02-03 11:53:35 UTC
ALG: Checked, happens as described. It is enough to break the group from the test document and to use only the top-left graphic object. Taking over.
Comment 5 Armin Le Grand 2012-02-03 11:56:32 UTC
ALG: Problem is that the exporter using the primitive to metafile converter uses the GraphicManager paint for the bitmap. There, the mirror flags are added to information handed to the GraphicManager, so the unrotated, unsheared and unmirrorred boundrect is needed as destination since the GM will do the mirroring. That boundrect was created without adaption of the translation to the existing mirrorings.

ALG: Corrected that, works well. Doing some more tests...
Comment 6 Armin Le Grand 2012-02-03 11:58:23 UTC
ALG: Okay, comitted, done in revision 1240097.