Issue 118914

Summary: Upgrade package missing
Product: Installation Reporter: zhao xia <doudou1976>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Normal    
Priority: P2 CC: arielch, issues, jsc
Version: 3.4.0 Beta (OOo)Flags: jsc: 3.4_release_blocker-
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description zhao xia 2012-02-15 02:42:22 UTC
Build: dev snapshot Rev. 1240836

In previous OO release, for example, OO 3.3, this is "update" package under root package. And this is the previous esay upgrade mechanism. But now, this package is missing.
Comment 1 zhao xia 2012-02-15 02:42:47 UTC
Mark it as 3.4 blocker
Comment 2 Olaf Felka 2012-02-17 08:51:47 UTC
reassigned
Comment 3 jsc 2012-03-08 16:44:11 UTC
I have to confess that I don't really know what it means.

We have a target in instset_native/util to build a "updatepack" but it breaks on my Linux system when it tries to build a Germany language pack. But I have no language selected and it should build en-US only. 

Do we really have problems with an upgrade on Linux systems?
Comment 4 Olaf Felka 2012-03-08 16:47:42 UTC
As far as I remember this has been used by the Java GUI installer and is not really needed. The package manger of the Linux distros could handle this. So I don't think that this is a stopper.
Comment 5 Ariel Constenla-Haile 2012-03-08 20:48:43 UTC
(In reply to comment #0)
> Build: dev snapshot Rev. 1240836
> 
> In previous OO release, for example, OO 3.3, this is "update" package under
> root package. And this is the previous esay upgrade mechanism. But now, this
> package is missing.

what do you mean by "update package"?

Is it the "update" shell script?
Comment 6 jsc 2012-03-09 17:44:16 UTC
no showstopper because of the lack of knowledge what exactly this package has done and how to build it.

Installation is possible in general