Issue 119162

Summary: two copies of ooobasis packages after upgrade from oo3.3 to 3.4 on Suse 11 SP1 and soffice will crash after open a file
Product: Installation Reporter: louqle <louqingle>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CLOSED FIXED QA Contact:
Severity: Critical    
Priority: P2 CC: doudou1976, jsc, kschenk, yanji.yj
Version: 3.4.0Flags: jsc: 3.4_release_blocker-
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Description Flags
ooobasis none

Description louqle 2012-04-01 05:20:48 UTC
build: r1303653

1. Install oo 3.3 and the desktop-integration menu package
2. upgrade to 3.4 by command: rpm -Uvh o*.rpm

all ooobasis packages and openoffice packages are upgraded successfully.

3. run command: rpm -qa | grep ooobasis

ooobasis3.3 packages are remain....

screenshot about terminal are attached..
Comment 1 louqle 2012-04-01 05:21:37 UTC
Created attachment 77395 [details]
Comment 2 louqle 2012-04-01 05:22:07 UTC
Created attachment 77396 [details]
Comment 3 louqle 2012-04-05 05:11:07 UTC
launch oo3.4 and open a document, wait for minutes, it will crash....
Comment 4 zhao xia 2012-04-05 16:36:36 UTC
If this is always reproduced, I agree it is release blocker.
Comment 5 louqle 2012-04-06 01:21:06 UTC
on ubuntu 10.04, there are two copies of ooobasis packages after upgrade from 3.3 to 3.4, and openoffice cannot be launched after upgrade. 

I run ./soffice in terminal and get the errors:

javaldx: Could not find a Java Runtime Environment!
Application Error

Fatal exception: Signal 6

I remove .openoffice directory and retry, the same error.
Comment 6 zhao xia 2012-04-06 01:55:03 UTC
From the two bugs on Linux platform, seems we have big problem on Linux upgrade. Should be release blocker.
Comment 7 Yan Ji 2012-04-06 05:42:59 UTC
The problem here is while upgrading too AOO 3.4, the previous installed OO3.3 was not removed. package is still in system. The coming crash problem is caused by conflicted existing product(3.3 and 3.4). If remove previous version, the crash problem will be fixed.
Comment 8 Kay 2012-04-10 21:30:04 UTC
Additionally confirmed just now.

I also used the rpm -Uhv, everything LOOKED fine via rpm.

Ran into a conflict trying to install --


but then did rpm -Uhv --force on this.

No joy on opening 3.4 at this point.

Deinstalled 3.3 at this point and now everything is OK.

I don't consider this a "release blocker" and don't exactly know why this happened. My guess is that changing significant aspects due to licensing changes may be at work here, but really, I don't know.

As near as I can tell, *deleting* 3.3 (the package) does no harm to user settings.
We should just put the deinstallation of 3.3 in the release notes and/or README and just get on our way.
Comment 9 Rob Weir 2012-04-11 00:09:39 UTC
When there is a problem, is it when installing over the real 3.3? Or when installing over the Go-OO version of 3.3 that Novell made?
Comment 10 Kay 2012-04-13 16:54:54 UTC
(In reply to comment #9)
> When there is a problem, is it when installing over the real
> 3.3? Or when installing over the Go-OO version of 3.3 that Novell made?

The REAL OOo 3.3. as this was NOT provided with my openSUSE 11.3 or 11.4 systems.

And again, I can't assist with troubleshooting this much more since I did indeed de-install all of the 3.3 components after this happened. I ahd NO problem installing 3.4 (a month or so ago) in a different location -- a new 'install" vs "U".
Comment 11 jsc 2012-04-16 15:34:14 UTC
as discussed on the mailing list this is no showstopper for 3.4 and we will provide a well tested cleanup solution for the next version. A workaround is in place and documented.
Comment 12 louqle 2012-07-18 08:52:10 UTC
Suse 11 sp1: 
Upgrade from 3.3 to 3.4.1, two copies of ooobasis packages. But no crash. the openoffice works normal

upgrade from 3.4 to 3.4.1, no problem.

Ubuntu 10.04:
upgrade from 3.3 to 3.4.1, the same error as that in comment 5
upgrade from 3.4 to 3.4.1, no problem.
Comment 13 Kay 2012-07-22 20:07:36 UTC
Installation of 3.4 over 3.3 via upgrade did not work unless 3.3 removed. Likely a problem with all Linux installations from 3.3. to 3.4 not just SuSE. This was noted in installation instructions for 3.4 as well.

Installation of 3.4.1 as upgrade to 3.4 works fine.
Comment 14 louqle 2012-08-28 05:41:47 UTC
when upgrade from 3.4 to 3.4.1, no this problem. Close this bug