Issue 119495

Summary: [From Symphony]Arrow style of line changes after save the sample file to a new .ppt file.
Product: Impress Reporter: Du Jing <bjdujing>
Component: save-exportAssignee: AOO issues mailing list <issues>
Status: CLOSED FIXED QA Contact:
Severity: Normal    
Priority: P3 CC: awf.aoo, lijianyuan1983, liushenf, phoenix.wanglf
Version: 3.4.0   
Target Milestone: 4.0.0   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
sample file
none
Patch for this issue
awf.aoo: review+
UT file for this issue none

Description Du Jing 2012-05-29 06:23:35 UTC
Created attachment 77690 [details]
sample file

Builds info: AOO3.4_1327774

Description:
1. Open the sample file.
2. Do not do any action and save as a new .ppt file.
3. Open the new .ppt file and the arrow style of the line changes.
Comment 1 Jianyuan Li 2012-07-11 03:36:39 UTC
I am investigating this issue.
Comment 2 Jianyuan Li 2012-07-11 03:36:57 UTC
Root cause:
ppt imported arrow styles is separately set into document model from AOO predefined arrow styles. When export, the two kinds styles also will be exported separately. But incorrect cross handling occurs for both.
Solution:
Separately handle them.
Comment 3 Jianyuan Li 2012-07-13 07:15:16 UTC
Created attachment 78636 [details]
Patch for this issue
Comment 4 Jianyuan Li 2012-07-13 07:16:26 UTC
Created attachment 78637 [details]
UT file for this issue
Comment 5 SVN Robot 2012-07-13 09:27:10 UTC
"af" committed SVN revision 1361125 into trunk:
#i119495# Fixed export of arrow styles to PPT.
Comment 6 Andre 2012-07-13 09:27:26 UTC
Comment on attachment 78636 [details]
Patch for this issue

Reviewed and tested: OK.
Comment 7 Andre 2012-07-13 09:27:39 UTC
Fixed.
Comment 8 Li Feng Wang 2012-08-21 05:25:37 UTC
Verified pass with AOO trunk r1374181