Issue 119532

Summary: [From Symphony]the bullet color display incorrectly in AOO3.4
Product: Impress Reporter: Du Jing <bjdujing>
Component: save-exportAssignee: Andre <awf.aoo>
Status: CLOSED FIXED QA Contact:
Severity: Normal    
Priority: P3 CC: awf.aoo, doneyourself, liushenf, sunyingshadesun, sunyty
Version: 3.4.0   
Target Milestone: 4.0.0   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
sample file
none
patch for ppt import bullet color display incorrectly
sunyingshadesun: review?
UT file none

Description Du Jing 2012-05-30 02:06:34 UTC
Created attachment 77741 [details]
sample file

build:AOO3.4_1327774

Steps:
1.open the sample file in AOO3.4
2.check the bullet color,and compare with in MS office

defect:
the bullet color from numbering 2 display incorrectly
Comment 1 SunYing 2012-06-08 04:57:07 UTC
I am checking this defect.
Comment 2 SunYing 2012-06-11 05:51:41 UTC
root cause:
In MS Office, if not set a bullet color, its color will be the same with the text after the bullet.
But if the text is hyperlink, the color changed in filter.
So need remember the original text color.
Comment 3 SunYing 2012-06-12 05:42:40 UTC
Created attachment 78243 [details]
patch for ppt import bullet color display incorrectly
Comment 4 SunYing 2012-06-12 05:43:34 UTC
Created attachment 78244 [details]
UT file
Comment 5 Andre 2012-06-12 15:35:38 UTC
@SunYing: Without access to MS Office I can not verify the bug fix, but the patch looks good, with one little exception.  There are some flags of type sal_Bool.  They are assigned "magical" values 0 and 1.  It would be better to use sal_False and sal_True instead.  Do you want to adapt you patch, or shall I do that when I commit it?
Comment 6 Andre 2012-06-13 07:59:09 UTC
Applied the patch together with the small changes that I mentioned above.
SVN revision is 1349670.
Comment 7 liuping 2012-06-21 08:28:58 UTC
confirm fixing the bug on ver 1351249 in Win7 ,pass