Issue 120096

Summary: wipe up and wipe down effect works fail in Aoo 3.4,but ok in OO3.3
Product: Impress Reporter: Du Jing <bjdujing>
Component: formattingAssignee: Andre <awf.aoo>
Status: CLOSED FIXED QA Contact:
Severity: Normal    
Priority: P3 CC: awf.aoo, jsc, phoenix.wanglf, polo8495
Version: 3.4.0Flags: jsc: 3.4.1_release_blocker+
Target Milestone: 3.4.1   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Du Jing 2012-06-26 08:03:03 UTC
build info:OOo_dev3.4.1 Rev.1351960

steps:
1.launch OO and new a presentation
2.set the slide transition as wipe up or wipe down

defect:
wipe up and wipe down effect doesn't play normally.
Comment 1 Du Jing 2012-06-26 08:09:00 UTC
add slide transition effect: box out effect is also lost
Comment 2 Terry Yang 2012-06-26 09:22:00 UTC
Confirm at my side
Comment 3 jsc 2012-06-29 11:27:52 UTC
set release blocker flag for 3.4.1
Comment 4 Andre 2012-07-02 13:07:20 UTC
Taking over.
Comment 5 Andre 2012-07-03 09:45:32 UTC
I can not yet see the problem with the wipe effects.  I created a new presentation with two shapes.  Via the "Custom Animation" dialog I assigned the effect Entrance/Basic/Wipe to one shape and Exit/Basic/Wipe to the other.  In the slideshow both effect look as expected.

@bjdujing: Did you use the effects I mentioned above?  What exactly means "doesn't play normally"?
Comment 6 Du Jing 2012-07-04 06:50:14 UTC
(In reply to comment #5)
> I can not yet see the problem with the wipe effects.  I created a new
> presentation with two shapes.  Via the "Custom Animation" dialog I assigned
> the effect Entrance/Basic/Wipe to one shape and Exit/Basic/Wipe to the
> other.  In the slideshow both effect look as expected.
> 
> @bjdujing: Did you use the effects I mentioned above?  What exactly means
> "doesn't play normally"?

Hiļ¼Œthe defect is about "slide transition",no custom animation.
and the defect is only happened on the linux.
Comment 7 Andre 2012-07-04 13:07:27 UTC
Ah, I see. Thanks.

The problem is that the effect is not visible, the second slide is fully visible at once.  From the debugger I can see that the effect is active though.

Additionally, the bug can be reproduced on Windows, too.  Use Tool->Options->View to turn of hardware acceleration.  Changing platform to all.
Comment 8 Andre 2012-07-05 09:18:40 UTC
This is a clipping problem.  For the very first frame of the animation the clip rectangle is empty.  This is handled incorrectly and is interpreted as no clip.  Result: the whole incoming page is painted.  The following frames are painted correctly (but that is not visible because the first frame already uncovered the whole slide.)

Bug 118855 seems to fix a similar problem.

There are at least two ways to fix this:

- Handle regions with empty clip polygons correctly.  This might lead to regressions though.

- The clip area in the wipe animations is rectangular.  The Region objects that represent the clip areas could use one band instead of the original polygon.  That would fix the bug and would be an optimization.
Comment 9 Andre 2012-07-05 15:55:42 UTC
Bug 118855 and previous and a previous change of VCL's Region class (support of polygons) are the root cause: the animation uses an empty clip polygon for the first frame.  This is not correctly detected by the Region object that is created to wrap the polygon.  The resulting region is then interpreted as "no clip" instead of "empty clip area" and the whole new slide is painted.

Fixed by improving the Region constructor that handles B2DPolyPolygons so that it detects empty polygons and represents them as an empty region.

SVN revision on trunk is 1357698.
Comment 10 SVN Robot 2012-07-10 12:46:10 UTC
"af" committed SVN revision 1359641 into branches/AOO34:
#i120096# Detect empty polygon in Region constructor and set impl object acco...
Comment 11 Andre 2012-07-10 12:46:29 UTC
Merged fix to 3.4.1 branch.
Comment 12 Li Feng Wang 2012-07-17 08:37:24 UTC
Verified steps:
1)create a new presentation 
2)create two slides, and enter some words in title
3)set the first slide with Wipe Up Transition, then check the Wipe up preview
4)set the second slide with Wipe Up Transition, then check the Wipe down preview
5)Press F5 to Slide show

Results:
1)Wipe up preivew is correct in the first slide.
2)Wipe down preview is correct int the second slide.
3)After slide show, the first slide show is ok, but the second slide is fully visible at once. the wipe down transition take effect on text in title, not total slide.

build:
AOO341 branch r1359641 on Windows XP
Comment 13 Andre 2012-07-17 13:14:56 UTC
I can not reproduce the new problems.

@Li Feng Wang: Can you provide an example file that shows the problem?
Comment 14 Li Feng Wang 2012-07-18 07:15:38 UTC
Sorry, I use default master page. And two slides are all white. So I can't see the effect in the second slide.

Pass wih AOO341 branch r1359641 on Windows XP
Comment 15 Li Feng Wang 2012-07-18 09:49:42 UTC
Verified pass on AOO trunk r1362376.
Comment 16 jsc 2012-07-25 09:24:23 UTC
set target milestone AOO 3.4.1