Issue 120158

Summary: [From Symphony]Time format is different than MS Office
Product: Writer Reporter: Yan Ji <yanji.yj>
Component: open-importAssignee: AOO issues mailing list <issues>
Status: CLOSED FIXED QA Contact:
Severity: Normal    
Priority: P3 CC: bjdujing, debin.lei, liushenf, zjchencdl
Version: 3.4.0   
Target Milestone: 4.0.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
sample
none
patch for i120158 zjchencdl: review?

Description Yan Ji 2012-07-03 02:18:26 UTC
Created attachment 78555 [details]
sample

Build: AOO 3.4.1

Open sample file check the variable time in footer

Defect: It is 'M/d/yyyy h:mm:ss a12/p12', actually, in MS Office it is 'M/d/yyyy h:mm:ss am/pm'.
Comment 1 zjchen 2012-08-09 01:28:46 UTC
The problem is that WW8 field filter mapped the "D/MM/YYYY HH:MM AM/PM" to "D\/MM\/YYYY HH:MM AM\/PM", and the "M" in the "AM\/PM" will be parsed isolatedly.
if we manually modify the "AM\/PM" to "AM/PM", the Time format displayed correctly.

The solution is that Do Not add "\" when parsing "AM/PM" token in datetime field code.
Comment 2 zjchen 2012-08-09 02:13:31 UTC
Created attachment 78888 [details]
patch for i120158
Comment 3 SVN Robot 2012-08-16 02:30:42 UTC
"leidb" committed SVN revision 1373703 into trunk:
#120158# fix Time format is different than MS Office issueReported by: Yan Ji...
Comment 4 Lei Debin 2012-08-16 02:32:14 UTC
Good patch, review pass.
Thx.
Comment 5 SVN Robot 2012-08-20 01:49:07 UTC
"leidb" committed SVN revision 1374894 into trunk:
#120158# fix picture shadow lost after saved as doc in some case.Reported by:...
Comment 6 Lei Debin 2012-08-20 01:58:26 UTC
wrong committed msg, sorry for my mistake.
Comment 7 Du Jing 2012-08-21 02:24:44 UTC
verified on the AOO3.5_r1374181