Issue 120714

Summary: Document created on en_US version of Base gives error when used on es_ES install
Product: Base Reporter: rgb <rgb.mldc>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Normal    
Priority: P3 CC: issues, mriosv, r4zoli
Version: 3.4.0   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: 4.0.0
Developer Difficulty: ---
Description Flags
Sample database none

Description rgb 2012-08-26 12:04:43 UTC
Created attachment 79148 [details]
Sample database

A valid database created on the English version of AOO Base 3.4.1 gives a "Syntax error in SQL expression" when opened on the Spanish version. 

== Steps to reproduce the problem

1- Open the attached "biblio.odb" database on a Spanish version of AOO.
2- Select "Consultas"
3- Right click on Consulta1 → Editar
4- Run it with F5 (Ejecutar)

Result: a pop up window with the following message 

"Syntax error in SQL expression"

NOTE: The same steps performed on an English AOO work without problems. 


The problem was first reported on the ES forums
Comment 1 r4zoli 2012-08-26 13:02:43 UTC
In the example file only "Consulta1" query exists. No "Consultas".

It is run without any problem with installed spanish langpack on Hungarian version AOO 3.4.1 under win7.

What platform you have this problem? All?
If you install other langpacks than spanish, change happens?

What is the query in SQL view? What happens if you run SQL direct option?
Comment 2 rgb 2012-08-26 13:15:55 UTC
>> In the example file only "Consulta1" query exists. No "Consultas". 

Yes. "Consultas" is not a query, but the Spanish name of the second icon on the left panel when you open the file. 

The original reporter found the problem on Win7 ultimate. I opened the file on Linux (64 bits) and got the same error message with AOO 3.4.1, full ES install (no Language Pack). 

For your other questions, I'll ask the original reporter and came back here.
Comment 3 r4zoli 2012-08-26 17:14:11 UTC
Now I tested with Xubuntu 12.04 32 bit AOO 3.4.1 Hungarian with Spanish langpack. I met the problem which you described only when I used Spanish UI settings. When I opened in HU settings no such problem. 

When I opened with Spanish UI, I opened query in SQL edit mode, I can run query. If I switched to query designer view, the error happens when I run query.

The problem somwhere in spanish query UI code,
Comment 4 mriosv 2012-08-26 23:05:42 UTC
Win7x64Ultimate AOO-3.4.1 Build 9593 Rev. 1372282  En-Us langpack-Es (Español) langpack-Gl (Galician)

The problem is only with Spanish-Spain language interface.

When in edit the view, if I try to run:
-Syntax error in SQL expression.
- Options:
  Lista de errores 
  X Error
  - Estado SQL:HY000
  - Código de error:1000
  - Syntax error in SQL expression.
  X Error
  - Estado SQL:HY000
  - Código de error:1000
  X Error
  - Estado SQL:HY000
  - Código de error:1000
  - syntax error, unexpected $end, expecting

When in edit the view, if I try to deactivate design view:
- Error en la sintaxis de SQL
- Options:
  Detalles (details)
  Lista de errores (list of errors)
  X Error
  - Estado SQL:HY000
  - Código de error:1000
  - Error en la sintaxis SQL.
Comment 5 rgb 2013-07-26 21:15:51 UTC
Problem still present on ES version for AOO 4.0:

AOO400m3(Build:9702)  -  Rev. 1503704
2013-07-16 14:49:37 (Tue, 16 Jul 2013) - Linux x86_64