Issue 121311

Summary: Report wizard creates broken report when using a query instead of a table
Product: Base Reporter: jojasch <kryb>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Major    
Priority: P3 CC: george.gentili
Version: 3.4.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: 3.4.1
Developer Difficulty: ---
Description Flags
Test database. Try report from query and from table...
original file. try report Geburtstage
database with suggested workaround none

Description jojasch 2012-11-05 09:52:07 UTC
Created attachment 79859 [details]
Test database. Try report from query and from table...

I found the bug using base on OOo 3.4.1 (Win XP and Mac OS X 10.8.2). In OOo 3.3.x it was still working.

First I tried to use my reports from 3.3.x: they still worked, but the order options were ignored. The data was filled in in order of the data in the main table :(

Now I started to search and tried to make a new report. It only showed me the template and didn't fill in the data. :(

Now I created a new document (attached) and first found out the report wizard works well. (Except for the missing document title: bug 49331). Now I tried to make a query and build the report from the query and now it happened: No filled in data, only the template...

The report from the table works, but the report from the query stays empty (shows the template without data).

I tested both on Win XP and on Mac OS X 10.8.2.
Comment 1 jojasch 2012-11-05 10:19:19 UTC
Created attachment 79860 [details]
original file. try report Geburtstage

This is the original file. i filled in some data to show the problem of wrong order in the report Geburtstage. The report is created with order options 1. Month (Monat), 2. Day (Tag)... It doesn't sort at all.
Comment 2 jojasch 2012-11-05 13:16:29 UTC
there is a workaround for the sorting problem beginning with in the original file: 

open the query and add the right sorting options, wiev as sql, copy the sql command

open the report in edit mode. open the form navigator and select the command and choose properties. paste the sql command into the empty command field and save the report.

but this doesn't fix the main bug.
Comment 3 gg43 2013-02-19 23:27:20 UTC
Operating System: Windows 7 Home Premium Version 6.1.7601 Service Pack 1 Build 7601 (x64)
Apache Open Office 3.4.1 AOO341m1 Build 9593 Rev 1372282

Confirm the bug

I suggest as a workaround to generate a query with the sorted data for the report and then create a view from the query.
Reports must have as input the view and so work either statically or dynamically

In the example posted by jojash simply generate a view from the query and create a new report with the view instead of query as input.

I attach the database testdb changed with the workaround suggested.
Comment 4 gg43 2013-02-19 23:30:38 UTC
Created attachment 80303 [details]
database with suggested workaround

see previous comment
Comment 5 gg43 2013-02-19 23:32:05 UTC
Modified Latest confirmation and QA Contact