Issue 121377

Summary: [dBase] adding new entry adds cryptic letters to empty fields which crashes some functions
Product: Base Reporter: Johanna <groove>
Component: codeAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact: Javier Lopez <xavi_dandy>
Severity: Normal    
Priority: P3    
Version: 3.4.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows 7   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Johanna 2012-11-20 09:08:13 UTC
We have a form (.odt) connected to a dBase (.dbt/.dbf) to change existing fields in rows and enter new rows. after updating from 3.3 to 3.4.1 with every new entry (row) strange characters get automatically filled into the empty fields.
After saving the new entry and checking back this entry in the former empty fields are than a lot spaces. By copying this fields with a macro to the clipboard they were displayed in writer as many #### and can't get pasted (control+v) into Editor. By exporting the dbase into .xls the characters are shown as many ????. This only happens with new rows, not with changing fields in old rows. We didn't change anything to the form or the macro. We just did update from 3.3. to 3.4.1. 

e.g. we have the fields Title, Name, Street, Street2, City 
starting a new entry (row) filling out only Name, Street and City
and saving
looking for a different address
looking for the "new" one:
Title and Street2 got filled with spaces (in the form, in the table it *looks* empty/ok, in the .xls export it's a lot of "?") the other fields are fine.
Copying all fields by macro into clipboard and pasting in writer: "################## Name Street ############################# City" 
doesn't paste anything in Editor 
If we now delete all the spaces in the empty fields by hand and save again, everything is fine again.