Issue 121417

Summary: [Automation][Regression]Page number can not be updated correctly until you moved the document. linux32 only.
Product: Writer Reporter: Li Lin Yi <lilinyi921734>
Component: open-importAssignee: AOO issues mailing list <issues>
Status: CLOSED IRREPRODUCIBLE QA Contact:
Severity: Normal    
Priority: P3 CC: awf.aoo, elish, fanyuzhen, issues, jsc, orw
Version: 4.0.0-devKeywords: automation_bug, regression
Target Milestone: ---Flags: jsc: 4.0.0_release_blocker-
Hardware: All   
OS: Linux 32-bit   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
page number location in staus bar none

Description Li Lin Yi 2012-11-28 05:40:24 UTC
Created attachment 79961 [details]
page number location in staus bar

Build: r1413470

Found by GUI Performance automation test. Ubuntu 12.04 32bit.

Reproduce steps:
1. Launch AOO
2. Open the sample files.
Sample file:
https://svn.apache.org/repos/asf/incubator/ooo/trunk/test/testgui/data/pvt/plain_200p.docx

Actual Result: This file contains 194 pages. Opened the sample file, wait for a long time(1 miuntes), the page number still keeped to "Page 1/176" not "Page 1/194" in status bar. Moved to the end of the document and moved back to 172 page, then the file number started to updated to "Page */194".

The attachment file showed the page number location in status bar.

Regression info:
   The problem is OK in 341 release build 1372282.
Comment 1 Oliver-Rainer Wittmann 2013-07-02 14:09:48 UTC
I could not reproduce the described defect with recent developer snapshot on Windows 7

scenario 1:
- opening the document
- waiting for 30 seconds
--> page count has reached 183
- jump to the end of the document does not change the layout - page count stays at 183

scenario 2:
- opening the document
- force page formatting via Menu Tools - Update - Page Formatting
--> page count reached 183
- jump to the end of the document does not change the layout - page count stays at 183

--> no release blocker
Comment 2 jsc 2013-07-02 14:53:11 UTC
remove showstopper request
Comment 3 Oliver-Rainer Wittmann 2014-02-25 15:03:04 UTC
Not reproducible in recent builds from trunk - waiting for planned 4.1.0 Beta for verification.
Comment 4 Andre 2014-02-28 13:55:21 UTC
Loading the bugdoc causes a crash which is covered (and fixed) by bug 123345.
Comment 5 Edwin Sharp 2014-04-15 18:34:36 UTC
page number OK
AOO410m17(Build:9763)  -  Rev. 1586584
2014-04-11 09:13 - Linux x86_64
Debian