Issue 121772

Summary: Insert - Object - PlugIn fails with error message
Product: Installation Reporter: vipin <vipinchinde>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Major    
Priority: P3 CC: arielch, awf.aoo, dfrost, doneyourself, email2akriti, hennerd, issues, jsc, oooforum, rainerbielefeld_ooo_qa, rb.henschel
Version: 3.4.1Flags: jsc: 4.0.0_release_blocker-
Target Milestone: ---   
Hardware: All   
OS: Windows 7   
Issue Type: PATCH Latest Confirmation in: 4.0.0
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 101890    
Attachments:
Description Flags
.swf Example to test plug-in feature
none
Error Box when trying to browse looking for a plugin to insert
none
Bring back the plugin none

Description vipin 2013-02-14 11:35:23 UTC
open openoffice
1)edit Menu
2)Select Plugin
3)the plugin selected is not showing any exception or not working
Comment 1 Regina Henschel 2013-02-14 13:23:13 UTC
Created attachment 80280 [details]
.swf Example to test plug-in feature
Comment 2 Ariel Constenla-Haile 2013-02-14 13:40:10 UTC
Created attachment 80281 [details]
Error Box when trying to browse looking for a plugin to insert

Select menu Insert - Object - Plug-in...

On the "Insert Plug-in" dialog, select "Browse...", the attached error box appears.

The component implementing the service "com.sun.star.plugin.PluginManager" cannot be instantiated.

This component was removed trunk/main/extensions/source/plugin/ due to incompatible license.
Comment 3 Ariel Constenla-Haile 2013-02-14 13:51:47 UTC
 np_sdk removed with revision 1305304

Opengroking "com.sun.star.plugin.PluginManager" shows the removal was incomplete.
Comment 4 Ariel Constenla-Haile 2013-02-15 02:30:24 UTC
(In reply to comment #1)
> Created attachment 80280 [details]
> .swf Example to test plug-in feature

Did inserting a plug-in ever worked before? I tried with 3.4.0-BETA OOO340m0 Build 9583, and all I get is a gray rectangle.

I re-introduced the deleted code, using the mozilla headers instead of the np_sdk ones, the code compiles fine, but I get the same gray rectangle.

So I'm uncertain if we should remove completely ".uno:PlugInsActive" and ".uno:InsertPlugin" from the menus, with all the respective code; or leave them, and give the plug in a try, may be someone wants to jump in and fix what's broken (I do not volunteer as I don't understand the code).
Comment 5 Regina Henschel 2013-02-15 11:32:56 UTC
I'm sure it works for .swf files in OOo3.2.1 and LO4.0 on Windows 7 and WinXP. I don't remember, whether it works for other formats in older versions. It is useful, when you want to show .swf-Animations in a presentation.

To test it, use an Impress file, goto Insert > Object > Plug-In and browse to a .swf-file (for example the attached one).

The original reporter wrote about Edit > Plug-in. That is only a toggle to switch between "edit" and "show" mode. In "edit" mode you have the normal context menu and can for example determine the position of the inserted .swf-animation. You see the animation preview in the middle of the slide. The green-handle frame can be at another position, in presentation mode the animation is shown at the position of the green-handle frame. In "show"-mode the context menu is that of the flash player.
This toggle should only be enabled, if there is such "plug-in" inserted. (Some as the item "Links" is only enabled, if there exists linked pictures.)

It would be nice, if insert of .swf-files would be made available again, because .swf-animations cannot be inserted via the OLE-mechanism. So I suggest to hide the menu-items, but keep the code.

Hiding the menu-items sounds like an "easy hack".
Comment 6 Ariel Constenla-Haile 2013-02-24 19:11:23 UTC
Created attachment 80356 [details]
Bring back the plugin

This patch brings back the plugin, compiling it with the in-tree mozilla.
It doesn't fix the underlying bugs, it's just to test if it is worth bringing it back.
Comment 7 Rainer Bielefeld 2013-06-18 05:29:09 UTC
*** Issue 120443 has been marked as a duplicate of this issue. ***
Comment 8 Rainer Bielefeld 2013-06-18 05:42:46 UTC
Still Reproducible with "AOO 4.0.0-Dev – English UI / German locale [AOO400m2(Build:9701)  -  Rev. 1493305
Rev.1491054  2013-06-14]" on WIN7 Home Premium (64bit)", own separate user profile

Already a prolbem with 3.4.0

Worked fine with 3.1.1, so regression

I don't think that classification as "Extensions" bug is very useful, Installation for now, may be someone finds a better classification?
Comment 9 jsc 2013-06-24 13:24:00 UTC
set showstopper flag

120443 was already proposed as showstopper but marked as duplicate to this issue
Comment 10 Andre 2013-06-28 08:33:10 UTC
I tried to insert the plugin provided in comment 1 to older versions of OpenOffice.org (all run in a Windows7 virtual machine) and it did not work in any of them.
Versions 2.2.1 and 3.0 initially show an OLE placeholder icon.  After that the plugin shape was not or not correctly repainted.  No reaction to double left click or single right click.

Version 3.2.1 was not much better.  No repaint error but a double click only shows a small dialog with the text "General error".

So, can anybody explain, what I have to do to get this to work in an older version?
What exactly is the "Edit -> Plug-In" menu entry supposed to do?
Comment 11 SVN Robot 2013-06-28 09:11:27 UTC
"af" committed SVN revision 1497691 into trunk:
121772: Prevent a crash when no plugin filter is present.
Comment 12 Andre 2013-06-28 09:12:29 UTC
Made a small change in the VistaFilePickerImpl to prevent a crash on Windows when the plugin service is not found and does not provide filter names to the file picker.
Comment 13 jsc 2013-07-05 09:48:13 UTC
remove showstopper flag, small fix to prevent crash but the issue can't be fixed completely in time. Needs further investigation...
Comment 14 hennerdrewes 2013-08-15 12:08:47 UTC
Please bring this functionality back!

I have used flash animations extensively in my presentations, which I need to run now in old OpenOffice versions.

There have been a number of strange behaviors with these plugins, but it was possible to run flash animations in a presentation.
Comment 15 Ariel Constenla-Haile 2013-09-18 17:44:14 UTC
*** Issue 123291 has been marked as a duplicate of this issue. ***
Comment 16 Edwin Sharp 2014-02-03 08:45:11 UTC
*** Issue 124167 has been marked as a duplicate of this issue. ***
Comment 17 Regina Henschel 2015-09-23 20:14:13 UTC
*** Issue 126551 has been marked as a duplicate of this issue. ***
Comment 18 oooforum (fr) 2016-02-06 23:00:45 UTC
(In reply to Ariel Constenla-Haile from comment #6)
> Created attachment 80356 [details]
> Bring back the plugin
> 
> This patch brings back the plugin, compiling it with the in-tree mozilla.
> It doesn't fix the underlying bugs, it's just to test if it is worth
> bringing it back.

Set type to "patch"