Issue 122093

Summary: [sidebar] layouts disappear in Slide Master View
Product: Impress Reporter: ipark321
Component: uiAssignee: Andre <awf.aoo>
Status: RESOLVED FIXED QA Contact:
Severity: Normal    
Priority: P3 CC: awf.aoo, issues, orw
Version: 4.0.0-dev   
Target Milestone: 4.0.0   
Hardware: PC   
OS: Windows 7   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 121420    

Description ipark321 2013-04-18 22:36:37 UTC
-Fails AOOTest-1134

Step 3 -- Switch view, say to Slide Master View, and View should be changed, and available page layout in sidebar should display and work correctly.


1.  New a Impress.
2.  Switch to Slide Master View.
3.  Click on blank Slide area or slide itself.  (All available Layouts disappear in sidebar!)
4.  To get Layouts back, Close Master View, click on any other tabs besides Normal (Outline, Notes, Handout, Slide Sorter), then back to Normal tab.  Available Sidebar Layouts re-appear!

5.  Disappearance of Sidebar Layouts in Slide Master View stops when only the 'Notes' tab is selected to re-appear Sidebar Layouts.
Comment 1 Andre 2013-04-23 15:33:29 UTC
The layout panel does not support the master page mode.  Have to find a way to make it disappear.
Comment 2 SVN Robot 2013-04-24 08:35:03 UTC
"af" committed SVN revision 1471290 into trunk:
122093: Don't show Impress layouts panel for master pages.
Comment 3 Andre 2013-04-24 08:36:40 UTC
The DrawController now broadcasts view switches as context changes.  This includes changes from and to the master page mode.  This hides the layout panel in master page mode because the master page context is not part of the context list for which the panel is displayed.
Comment 4 SVN Robot 2013-04-25 08:10:45 UTC
"af" committed SVN revision 1475665 into trunk:
122093: Avoid compiler warning in DrawController::BroadcastContextChenge().
Comment 5 Andre 2013-04-30 07:18:00 UTC
*** Issue 122106 has been marked as a duplicate of this issue. ***