Issue 122104

Summary: [sidebar] No tab bar button is selected.
Product: General Reporter: Andre <awf.aoo>
Component: codeAssignee: Andre <awf.aoo>
Status: RESOLVED FIXED QA Contact:
Severity: Normal    
Priority: P3 CC: issues
Version: 4.0.0-dev   
Target Milestone: 4.0.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Andre 2013-04-19 15:19:22 UTC
In certain circumstances there is no tab bar button selected.

How to reproduce:
1. Open a new Writer document.
2. Insert a shape.
3. Deselect the shape.

The button of the property deck should be selected but isn't.
Comment 1 SVN Robot 2013-04-19 15:27:17 UTC
"af" committed SVN revision 1469899 into trunk:
122104: Fixed selection of sidebar button.
Comment 2 Andre 2013-04-19 15:28:29 UTC
On a context switch both the deck and the tab bar are updated.  But there where different optimizations to prevent unnecessary work.  Looks like the tab bar button update was less optimized: the tab bar buttons are sometimes destroyed and created again after the deck is modified.  But the selection of the button for the current deck was updated from within the deck update method.

Fixed by updating the button selection at a better time.