Issue 122321

Summary: [sidebar] undock by dragging is no longer possible
Product: General Reporter: Regina Henschel <rb.henschel>
Component: uiAssignee: Andre <awf.aoo>
Status: RESOLVED FIXED QA Contact:
Severity: Normal    
Priority: P3 CC: awf.aoo, issues, rainerbielefeld_ooo_qa
Version: 4.0.0-dev   
Target Milestone: 4.0.0   
Hardware: PC   
OS: Windows 7   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 121420    

Description Regina Henschel 2013-05-15 11:38:54 UTC
At least till snapshot r1478648 it was possible to undock this way:
Click on desk title and hold mouse button down.
Drag. You can see dotted lines.
Drop it at the new place.

That is a common behavior for docked windows.

This undocking by dragging is no longer possible in r1482523.
Comment 1 Rainer Bielefeld 2013-05-16 05:39:34 UTC
Effect is reproducible with server installation of  "AOO 4.0.0-Dev – English UI / German locale [AOO400m1(Build:9700) - Rev. 1482523 Rev.1482259 (2013-05-15)]" on WIN7 Home Premium (64bit)", own separate user profile

Undocking with drag and drop was possible with Rev.1476029 and  Rev. 1479897

Bug or feature? I think it's a bug.
Comment 2 Andre 2013-05-16 08:38:36 UTC
Definitely a bug.
Comment 3 Andre 2013-05-16 11:10:51 UTC
This was caused by my recent changes to support scroll wheels.  The new Deck::Notify() method did not pass other events to its super class.
Comment 4 SVN Robot 2013-05-16 11:19:17 UTC
"af" committed SVN revision 1483297 into trunk:
122321: Fix processing of scroll whell to not block other events.