Issue 122529

Summary: [sidebar] Math OLE cannot be moved with arrow keys
Product: Writer Reporter: Regina Henschel <rb.henschel>
Component: editingAssignee: Oliver-Rainer Wittmann <orw>
Status: CLOSED FIXED QA Contact:
Severity: Normal    
Priority: P3 CC: doneyourself, issues, jsc, orw, vstuart.foote
Version: 4.0.0-devKeywords: accessibility, regression
Target Milestone: 4.0.0Flags: jsc: 4.0.0_release_blocker+
Hardware: PC   
OS: Windows 7   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 121420    
Attachments:
Description Flags
Math OLE in text for testing none

Description Regina Henschel 2013-06-12 15:34:21 UTC
Created attachment 80841 [details]
Math OLE in text for testing

Open attached document. The first formula is anchored to paragraph. You should be able to move the formula around with arrow keys, simple arrow key for large movements and ALT-arrow key for pixel movements.
The second formula is anchored as character. Therefore only up and down movements should be possible, but that is not the case.

Especially Alt-arrow key is needed for manual alignment of inline formulas.

It worked till r1453677 which was a version without sidebar and is broken at least in version r1466899, which is a version with sidebar.

The sidebar integration might not be the reason, but the bug was introduced in the time range where the sidebar has been integrated.

Because not working keyboard is an accessibility problem, it should be solved before release.
Comment 1 V Stuart Foote 2013-06-12 16:28:23 UTC
Confirming issue with cursor only positioning a formula object, and adding accessibility keyword.

But cursor positioning and observing wrapping settings with inserted picture objects (tested a JPEG) remains correct.

But, doesn't really seem to be a sidebar specific issue.
Comment 2 Oliver-Rainer Wittmann 2013-06-13 11:09:07 UTC
I will have a look as I had recently made a change to the arrow-key handling in Writer - revision 1488232
Comment 3 Oliver-Rainer Wittmann 2013-06-13 12:32:45 UTC
defect cause found:
It is a side effect which already exists in former version.
The defect that exists in former versions is that an anchored object (text frame, graphic, embedded one, drawing one) can not be moved via the arrow-keys, if its _size_ is protected.
For the Position and Size property sidebar I made a small change to the method which checks certain protection states especially for objects containing protected content like Formulas.

fix is in progress.
Comment 4 Oliver-Rainer Wittmann 2013-06-13 13:06:58 UTC
(In reply to Oliver-Rainer Wittmann from comment #3)
> defect cause found:
> It is a side effect which already exists in former version.
> The defect that exists in former versions is that an anchored object (text
> frame, graphic, embedded one, drawing one) can not be moved via the
> arrow-keys, if its _size_ is protected.

Correction: moving drawing object which are size-protected via arrow-keys works.

> For the Position and Size property sidebar I made a small change to the
> method which checks certain protection states especially for objects
> containing protected content like Formulas.
>
Comment 5 Oliver-Rainer Wittmann 2013-06-14 06:55:11 UTC
fixed on trunk for AOO 4.0 - revision 1492233
Comment 6 Oliver-Rainer Wittmann 2013-06-14 06:58:13 UTC
(In reply to Oliver-Rainer Wittmann from comment #5)
> fixed on trunk for AOO 4.0 - revision 1492233

Sorry - wrong revision - it is revision 1492675 which fixes this defect
Comment 7 jsc 2013-07-02 12:21:12 UTC
grant showstopper flag, it's fixed already
Comment 8 liuping 2013-07-10 06:36:59 UTC
verify on windows 7 on  Rev. 1499347