Issue 122867

Summary: save/export as html loses paragraph formatting
Product: Writer Reporter: Joe Smith <jes>
Component: save-exportAssignee: Oliver-Rainer Wittmann <orw>
Status: CLOSED FIXED QA Contact: Susi <sannugu>
Severity: Normal    
Priority: P3 CC: fanyuzhen, issues, jsc, kschenk, leptonjim, rb.henschel
Version: 4.0.0Keywords: regression
Target Milestone: 4.0.1Flags: jsc: 4.0.1_release_blocker+
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Sample document for testing
none
screen capture comparing 3.4.1 vs 4.0 exported html
none
patch to solve the defect none

Description Joe Smith 2013-07-28 00:52:29 UTC
Created attachment 81179 [details]
Sample document for testing

Paragraph formatting that was exported to html by AOO 3.4.1 is not exported by AOO 4.0

Steps to reproduce:
1) Open the attached Writer document
2) File > Save As > Type: HTML Document (OO Writer)

Examine the exported document: all paragraph-level formatting, from the paragraph style or directly applied, is not present in the exported file. Character-level formatting is exported correctly.

Expected result: paragraph formatting should be exported, as it was in AOO 3.4.1
Comment 1 Joe Smith 2013-07-28 00:56:44 UTC
Created attachment 81180 [details]
screen capture comparing 3.4.1 vs 4.0 exported html
Comment 2 Regina Henschel 2013-07-28 12:31:20 UTC
good in r1382027
broken in r1384746
Comment 3 Regina Henschel 2013-08-10 23:24:33 UTC
*** Issue 123005 has been marked as a duplicate of this issue. ***
Comment 4 Oliver-Rainer Wittmann 2013-08-26 11:55:56 UTC
fix in progress
Comment 5 Oliver-Rainer Wittmann 2013-08-26 12:01:05 UTC
Defect introduced by changes for bug 119612. Certain new items had been introduced, but corresponding item-export_function-tables for HTML export had not been adjusted. Bug 120935 fixes only one of the needed item-export_function-tables.
Comment 6 Oliver-Rainer Wittmann 2013-08-26 12:34:51 UTC
Created attachment 81389 [details]
patch to solve the defect
Comment 7 SVN Robot 2013-08-26 13:23:57 UTC
"orw" committed SVN revision 1517535 into trunk:
122867: HTML export - correct function pointer table which holds the export f...
Comment 8 jsc 2013-08-28 08:29:45 UTC
approve showstopper request
Comment 9 SVN Robot 2013-08-28 11:28:20 UTC
"orw" committed SVN revision 1518167 into branches/AOO401:
122867: HTML export - correct function pointer table which holds the export f...
Comment 10 Oliver-Rainer Wittmann 2013-08-28 11:29:48 UTC
fixed on trunk and on branch AOO401
Comment 11 fanyuzhen 2013-08-30 14:04:01 UTC
The latest build in wiki is AOO401m1(Build:9710)  -  Rev. 1516414, wait for revision 1518167 for verification
Comment 12 Kay 2013-09-01 22:19:15 UTC
Test verified as fixed -- back to output generated by 3.4.1 on linux-32, rev.1518670