Issue 123005

Summary: Margins are not saved in html
Product: Writer Reporter: leptonjim
Component: editingAssignee: AOO issues mailing list <issues>
Status: CLOSED DUPLICATE QA Contact:
Severity: Normal    
Priority: P3 CC: elish, issues, rb.henschel
Version: 4.0.0Keywords: needmoreinfo
Target Milestone: ---   
Hardware: PC   
OS: Windows 7   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description leptonjim 2013-08-10 19:20:29 UTC
With version 4 of the writer, when I save a file as a .stw file the margins I have created are saved. When I save it as a .html file, they are not. This appears to be a new bug with version 4. Even files created in version 3 get corrupted when I edit them with version 4.

Also, when I look at the html code for a file created in version 3, I see the margin settings within the <P> tag, but they goes away once edited and saved with verson 4.
Comment 1 Edwin Sharp 2013-08-10 19:27:07 UTC
Please specify steps to reproduce.
Comment 2 leptonjim 2013-08-10 21:18:55 UTC
(In reply to Edwin Sharp from comment #1)
> Please specify steps to reproduce.

Instantiate open office 4.0.

Select "Text Document" from the startup menu.

Type in a short line of text, starting at the left border of the window.

Select the entire line of text.

Drag the right "Set Left Indent" and "Set Left Indent of First Line" triangles to the right on the ruler.

Watch the text move to the right.

Save the file as both a .stw file.

Save the file as a .html file. 

Close out the file.

Open the .stw file and note that the text is where it should be.

Open the .html file and note that the text is aligned to the left border of the window. 

-----------------

Select the entire line of text.

Drag the right "Set Left Indent" and "Set Left Indent of First Line" triangles to the right on the ruler.

Watch the text move to the right.

Modify the text a little.

In the View menu select HTML Source.

Note that the margins you just set are not reflected in the html source. They should be in the <P> tag for the line of modified text.

It appears that the changed margins (which appear on the screen at the time the modification is made), never make it into the html source.
Comment 3 Regina Henschel 2013-08-10 23:02:14 UTC
The missing styles have no connection with .stw file format. The rules in the style element for paragraph styles are missing too, not only the style attribute for hard formattings.

The problem is already tracked in bug 119224.

*** This issue has been marked as a duplicate of issue 119224 ***
Comment 4 Regina Henschel 2013-08-10 23:24:33 UTC
Ups, wrong issue number.

*** This issue has been marked as a duplicate of issue 122867 ***