Issue 123197

Summary: Master view is reopened unexpected
Product: Impress Reporter: Thorsten Wagner <thorsten.wagner.4>
Component: uiAssignee: Andre <awf.aoo>
Status: CLOSED FIXED QA Contact:
Severity: Major    
Priority: P2 CC: Armin.Le.Grand, awf.aoo, doneyourself, ftempez, issues, leroy.tennison, peter.bluewin, rb.henschel
Version: 4.0.1-devKeywords: regression
Target Milestone: 4.1.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Thorsten Wagner 2013-09-05 22:50:34 UTC
Selecting a regular slide after editing a master slide causes the reopening of the master slide.

Steps to reproduce:

(1) Select "Master Pages" using the sidebar

(2) Select "Edit Master"

(3) Close master view

(4) Select a regular slide

After selecting a regular slide (step 4) the master view appears again.

Correct behaviour:

The selected regular slide should be shown.
Comment 1 cybertaf 2013-09-26 20:33:57 UTC
Same behavior on different computers :

Win 8 64 bits and Win XP 32 

See this video screen capture : http://frederic.tempez.free.fr/temp/impress.wmv
Comment 2 Regina Henschel 2013-09-26 22:23:23 UTC
Thanks for your report. Thanks cybertaf for the video. It makes is very easy to reproduce the error. Sadly, it is to late to fix it for version 4.0.1.

I can confirm it for Windows 7 (32bit).

The error exists already in r1488548, but not in r 1485289.
Comment 3 Regina Henschel 2013-09-26 23:15:57 UTC
First aid: Do not click into the slide pane, but traverse the slides via PageUp/PageDown key.
Comment 4 Armin Le Grand 2013-10-08 09:24:59 UTC
ALG: Tried, but could not reproduce in AOO410m1(Build:9750)  -  Rev. 1528376. Adding Andre to CC...
Comment 5 SVN Robot 2014-02-21 11:59:30 UTC
"af" committed SVN revision 1570539 into trunk:
123197: Fixed selection problems when switching between normal and master mode.
Comment 6 Andre 2014-02-21 12:04:40 UTC
I can not reproduce the actual bug but some problems with selection in the slidesorter when switching to/from master page mode.  Maybe both problems are related and my fix also fixes this issue?
Comment 7 Thorsten Wagner 2014-02-21 16:38:57 UTC
The bug seems to be disappeared with revision 1570624 from trunk. I suggest closing the ticket when AOO 4.1 becomes beta.
Comment 8 Andre 2014-02-24 08:10:30 UTC
@Thorsten: That is what I wanted to hear :-)
Thank you for checking this.
Seeting status to fixed.
Comment 9 liuping 2014-04-02 08:04:12 UTC
Verified on Windows 7 on AOO410ml4(Build:9750)  -  Rev. 1583418
Comment 10 leroy.tennison 2014-04-05 23:20:51 UTC
Unfortunately this is not fixed, just confirmed with A00 4.0.1 (AOO401m5(Build:9714)  -  Rev. 1524958
2013-09-20 11:54 - Linux x86_64)
Comment 11 mroe 2014-06-25 16:51:21 UTC
*** Issue 124751 has been marked as a duplicate of this issue. ***