Issue 123444

Summary: CRASH when choosing "Selection" radio button on "Print" dialog
Product: Writer Reporter: Rainer Bielefeld <rainerbielefeld_ooo_qa>
Component: printingAssignee: Oliver-Rainer Wittmann <orw>
Status: CLOSED FIXED QA Contact:
Severity: Normal    
Priority: P3 CC: clarence.guo.bj, issues, oliver.brinzing, orw, rainerbielefeld_ooo_qa
Version: 4.0.0Keywords: crash
Target Milestone: 4.1.0   
Hardware: PC   
OS: All   
See Also: https://issues.apache.org/ooo/show_bug.cgi?id=119189
https://issues.apache.org/ooo/show_bug.cgi?id=123063
Issue Type: DEFECT Latest Confirmation in: 4.0.1
Developer Difficulty: ---
Attachments:
Description Flags
Sample Document none

Description Rainer Bielefeld 2013-10-08 15:58:12 UTC
Created attachment 81728 [details]
Sample Document

I see that with any Writer document (Calc and Draw not affected) with any printer.

Steps how to reproduce with "AOO 4.0.1   – German UI / German locale  [Rev. 1524958 2013-09-20 11:40:29]" on  German WIN7 Home Premium (64bit)", “historic”  4.0  User Profile used for all  predecessor versions:

1. Open attached sample document from AOO start center
2. Select 2 dots on page 1 (does not matter what
3. Menu 'File -> Print -> General'
4. Click radio buttons for selection (one after the other) 'All Pages ->
   Pages -> Selection'
   Bug: CRASH when click 'Selection'                                     :-(

Additional info: 
(a) not related to Printer or document, I always see that
(b) Already reproducible with:
* "AOO 4.1.0-Dev – English  UI / German locale - [AOO410m1(Build:9750)  -  
   Rev. 1520414 Rev.1520414]" on German WIN7 Home
Premium (64bit)", own separate user profile.
(c) Was still ok with: 
* "AOO 4.0.0 Final – German UI / German locale -  [AOO400m3(Build:9702)  - 
   Rev. 1505643  2013-07-23]" on German WIN7 Home Premium (64bit)", 
   own separate user profile
* server installation of  " AOO 4.0.0-Dev  – English UI / German locale
  [AOO400m1(Build:9700) - Rev. 1457992 – Rev.1457606  ((2013-03-19))]" 
  on German WIN7 Home Premium (64bit)", own separate user profile 
(d) I also see the crash with same version Swedish UI
(e) PDF export not affected
(f) very similar to "Bug 119189 - Print Selection crash Writer when is chosen 
    again"

Some more tests later
Comment 1 Rainer Bielefeld 2013-10-08 16:33:53 UTC
(b) Already Reproducible with sever installation of "AOO 4.1.0-Dev – English  UI 
   / German locale - [AOO410m1(Build:9750)  -  Rev. 1516435  2013-08-24]" 
   on German WIN7 Home Premium (64bit)", own separate user profile.
(c) Was still ok with sever installation of "AOO 4.0.0-Dev – German UI 
    / German locale - [AAOO400m3(Build:9702)  -  Rev. 1513120  2013-08-13]"
    on German WIN7 Home Premium (64bit)", own separate user profile.
(g) Latest confirmation for AOO  4.1.0-dev, but because of incomplete LCo 
    selector (Bug Bug 123063) no correct information can be left.
Comment 2 Oliver Brinzing 2013-10-08 16:42:55 UTC
confirming crash
Comment 3 Ariel Constenla-Haile 2013-10-08 17:12:19 UTC
Reproduced on Linux 64 bit
Comment 4 Ariel Constenla-Haile 2013-10-08 18:21:44 UTC
Looks like related to Bug 122868 / Bug 121125
Setting orw on Cc
Comment 5 Oliver-Rainer Wittmann 2013-10-09 08:39:23 UTC
I reproduced the crash on my local trunk build (rev. 1527563)

Taking over to have a deeper look.
Comment 6 Oliver-Rainer Wittmann 2013-10-09 10:26:52 UTC
fix in progress.

this crash is caused by change made for bug 121125 and have been overseen in the corresponding fix (bug 122868)
Comment 7 SVN Robot 2013-10-09 10:47:26 UTC
"orw" committed SVN revision 1530557 into trunk:
123444: method <SwXTextDocument::getRendererCount(..)> - clear of rendering d...
Comment 8 Oliver-Rainer Wittmann 2013-10-09 10:51:06 UTC
fixed on trunk for AOO 4.1.0

IMPORTANT NOTE for verification:
Please double-check, if bug 121125 and bug 122868 are still fixed.
Comment 9 Rainer Bielefeld 2013-10-11 05:21:43 UTC
Fix VERIFIED with  "AOO 4.1.0-Dev – English  UI / German locale - [AOO410m1(Build:9750)  -  Rev. 1530680 - 2013-10-11]" on German WIN7 Home
Premium (64bit)", own separate user profile

Also VERIFIED  bug 121125 and bug 122868 with above mentioned version.
Comment 10 Oliver-Rainer Wittmann 2013-10-21 09:27:08 UTC
(In reply to Rainer Bielefeld from comment #9)
> Fix VERIFIED with  "AOO 4.1.0-Dev – English  UI / German locale -
> [AOO410m1(Build:9750)  -  Rev. 1530680 - 2013-10-11]" on German WIN7 Home
> Premium (64bit)", own separate user profile
> 
> Also VERIFIED  bug 121125 and bug 122868 with above mentioned version.

Thx for the fast verification.