Issue 123479

Summary: Repositioning automatically autosized Frames
Product: Writer Reporter: Matthieu Riolo <matthieu.riolo>
Component: editingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Normal    
Priority: P3 CC: denis.simonet, elish, issues
Version: 3.4.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
shows that frames will be pagedbreaked to the next page
none
Shows that the frame does not remove the pagebreak
none
shows the config AFTER changing anchortype
none
Shows that the pagebreak wont be removed
none
partial fix for this bug
none
Debugprints from the resize methods none

Description Matthieu Riolo 2013-10-15 13:16:11 UTC
Hello together

A customer of me has got a problem with the 3.4.1 version. After him, the problem came with the change from 3.3 to 3.4.

The problem is:
1. create a frame with a automatically resized height and with the anchortype: as character
2. add enough content to the frame that it must break the page
3. remove content from the frame (enough that the frame shall revert the page break)

Expected:
That pagebreak is reverted

What it really does:
The pagebreak simply stays

Best Regards, Matthieu Riolo
Comment 1 Edwin Sharp 2013-10-16 07:02:58 UTC
Removing content from frame makes it adjust accordingly.

AOO410m1(Build:9750)  -  Rev. 1525015
Rev.1525015
Win 7
Comment 2 Matthieu Riolo 2013-10-17 11:39:52 UTC
I just tried if with the new version and I still have got this problem.
Have you changed the anchor-option to "as character"?
Comment 3 Edwin Sharp 2013-10-17 12:52:12 UTC
Yes.
Can you please attach example?
Comment 4 Matthieu Riolo 2013-10-21 07:13:51 UTC
Created attachment 81787 [details]
shows that frames will be pagedbreaked to the next page
Comment 5 Matthieu Riolo 2013-10-21 07:14:30 UTC
Created attachment 81788 [details]
Shows that the frame does not remove the pagebreak
Comment 6 Matthieu Riolo 2013-10-21 07:15:03 UTC
Created attachment 81789 [details]
shows the config AFTER changing anchortype
Comment 7 Matthieu Riolo 2013-10-21 07:20:50 UTC
Here some more infos:

The pictures shows the following version of OO

AOO401m5(Build:9714)  -  Rev. 1524958
2013-09-20 11:41 - Linux i686

the first picture shows that a page break will be added.
the second one shows that the pagebreak will not be removed.
the third one shows that if the anchortype is changed that the pagebreak will be removed.

PS: Same behaviour in OO341
Comment 8 Matthieu Riolo 2013-11-12 15:20:10 UTC
Created attachment 81910 [details]
Shows that the pagebreak wont be removed
Comment 9 Matthieu Riolo 2013-11-12 15:21:45 UTC
I just tried out the newest version of OO and still got the bug. Actually the bug can be avoided by a simple trick and I think the most people does not recognize the bug since they use the trick (without knowing it)


However, hard to describe in words - that's why you get a movie. In the movie you can see that the frame height is resizing correctly but it does not undo the pagebreak.
Comment 10 Edwin Sharp 2013-11-12 17:51:46 UTC
Thanks for the video.
Confirmed with
AOO410m1(Build:9750)  -  Rev. 1539999
2013-11-09_04:08:11 - Rev. 1540252
Debian
Comment 11 Matthieu Riolo 2014-01-23 18:08:36 UTC
I tried to fix this bug but I wasn't really successful. I was able to detect the problem, why the frame does not move back to the original page but run into the problem that the frame changes the page evertime the height changed. I could fix that problem too, but run into the problem that the frame does not move back if there is a footnote anchor on his right...


the file partialFixFor-123479.patch contains the code that I added for "fixing" the bug. Maybe someone else sees the problem.


Furthermore, I recognized that the frames actually never moves back to a page while shrinking their content EXCEPT if they don't wrap any text. This would mean that the real bug is that the anchor of frames don't get repositioned correctly while changing the frame height. If this can be confirmed I would recommand to create a new ticket and discard that one.
Comment 12 Matthieu Riolo 2014-01-23 18:11:26 UTC
Created attachment 82376 [details]
partial fix for this bug
Comment 13 Matthieu Riolo 2014-01-28 16:42:37 UTC
Created attachment 82422 [details]
Debugprints from the resize methods

This may help other people to recognize the failure that occurs
Comment 14 Denis Simonet 2014-12-23 14:43:37 UTC
It still happens in AOO 4.1.1, but not in Libreoffice 4.3.4.1.