Issue 123562

Summary: In particular .pptx particular shape shown without hatching filling
Product: Impress Reporter: Rainer Bielefeld <rainerbielefeld_ooo_qa>
Component: open-importAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Normal    
Priority: P3 CC: Armin.Le.Grand, elish, issues, rainerbielefeld_ooo_qa
Version: 3.4.0Keywords: interop_OOXML
Target Milestone: ---   
Hardware: PC   
OS: Windows 7   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
PowerPoint vs. Impress none

Description Rainer Bielefeld 2013-10-28 05:35:14 UTC
Steps how to reproduce with "AOO 4.0.1   – German UI / German locale  [Rev. 1524958 2013-09-20 11:40:29]" on  German WIN7 Home Premium (64bit)", “historic”  4.0  User Profile used for all  predecessor versions

1. From AOO Start center open  Attachment 81812 [details] for Bug 123515
2. Open a copy of that document in MS PPT Viewer (or SoftMaker FreeOffice)
3. compare fillingin area of shape at X/Y 70/83mm:
   Views differ:
   (a) IN PPT Viewer I see some kind of hatching with blue dots
       AOO shows blank white area (Area properties also say 
       "filling: color white")
   
Additional info:
----------------
(b) not a new problem, all the same with OOo 3.3.0
(c) Still Reproducible with  "AOO 4.1.0-Dev – English  UI / German locale - 
    [AOO410m1(Build:9750)  -  Rev. 1534248 - 2013-10-22]" on German 
     WIN7 Home Premium (64bit)", own separate user profile.
(d) the problem might be that AOO has no such dots-hatching
(e) with AOO 4.1.0 I see some additional problems, I will report that later
(f) This one is a spin off from "Bug 123515 - In .pptx shape area "Slide 
    Background Filling" shown with color" reported by fanyuzhen@gmail.com
Comment 1 Edwin Sharp 2013-10-28 07:26:12 UTC
Created attachment 81831 [details]
PowerPoint vs. Impress
Comment 2 Edwin Sharp 2013-10-28 07:28:04 UTC
Confirmed with
AOO410m1(Build:9750)  -  Rev. 1525015
Rev.1525015
PowerPoint 2007
Win 7
Comment 3 Armin Le Grand 2013-10-30 16:23:20 UTC
ALG: Took a look, OOXML import does not (yet) support pattern fills, see FillProperties::pushToPropMap case XML_pattFill (there is a comment 'todo').
Thus: Change to enhancement.