Issue 123795

Summary: variable names should not confuse vcl Windows and cocoa NSWindows
Product: General Reporter: hdu <hdu>
Component: codeAssignee: hdu <hdu>
Status: CLOSED FIXED QA Contact:
Severity: Normal    
Priority: P4 CC: issues
Version: 3.4.0   
Target Milestone: 4.1.0   
Hardware: All   
OS: Mac OS X, all   
Issue Type: TASK Latest Confirmation in: ---
Developer Difficulty: ---

Description 2013-12-02 15:58:31 UTC
VCL's Window type and Cocoa's NSWindow type are quite different. Naming variables as if they were the same introduces gratuitous complexity for debugging stacks where the different types are both used. This should be cleaned up. The naming of variables of the related NSView type should be adjusted too.
Comment 1 SVN Robot 2013-12-02 16:10:30 UTC
"hdu" committed SVN revision 1547078 into trunk:
#i123795# variable names should not confuse vcl Window and cocoa NSWindow types
Comment 2 2013-12-02 16:12:38 UTC
Fixed with the commit above.
Comment 3 SVN Robot 2014-02-06 14:14:28 UTC
"hdu" committed SVN revision 1565258 into trunk:
#i123795# add a windowForParent() method for AquaA11yWrapper
Comment 4 SVN Robot 2014-02-06 15:05:55 UTC
"hdu" committed SVN revision 1565295 into trunk:
#i123795# amend r1565258's commit with its missing part