Issue 123941

Summary: Missing Pictures for headings "Arrow left" and "Arrow right"
Product: Writer Reporter: Rainer Bielefeld <rainerbielefeld_ooo_qa>
Component: helpAssignee: AOO issues mailing list <issues>
Status: RESOLVED FIXED QA Contact:
Severity: Minor    
Priority: P3 CC: hdu, issues, mseidel, rainerbielefeld_ooo_qa, rb.henschel, rbircher
Version: 3.3.0 or older (OOo)   
Target Milestone: 4.2.0   
Hardware: All   
OS: All   
See Also: https://issues.apache.org/ooo/show_bug.cgi?id=123063
Issue Type: DEFECT Latest Confirmation in: 4.1.5
Developer Difficulty: Simple
Issue Depends on: 106671    
Issue Blocks:    
Attachments:
Description Flags
Additional Info
none
next
none
previous none

Description Rainer Bielefeld 2014-01-01 09:30:10 UTC
Steps how to reproduce Reproducible with server installation of "AOO 4.1.0-Dev – English  UI / English locale - [AOO410m1(Build:9750)  -  Rev. 1554205 - 2014-01-01]" on German WIN7 Home Premium (64bit)", own separate user profile:

1. From AOO start center open blank new Writer Document
2. Menu 'Help -> OO Hepo -> Find "Footnote/Endnote" [Find]
3. Double click search result "Footnote/Endnote"
4. Scroll down, 
   > You will see placeholders instead of pictures at
     "Arrow left" and "Arrow right"

Additional Info:
----------------
Also missing at "Edit Fields"
Comment 1 Rainer Bielefeld 2014-01-01 09:57:42 UTC
(a) Was still ok with OOo 3.1.1
(b) Already Reproducible with 
* "AOO 4.0.1   – German UI / German locale  [Rev. 1524958 2013-09-20 11:40:29]" 
  on  German WIN7 Home Premium (64bit)", “historic”  4.0  
  User Profile used for all  predecessor versions at  "Fußnote bearbeiten"
* sever installation of "OOo 3.3.0 English UI / German locale 
  [OOO330m20 (Build 9567)]" on  WIN7  Home Premium  (64bit) DE
(c) CONFIRMED due to additional Versions where found
(d)  Already reproducible with  Pre-3.4.0 (OOo 3.3.0), but because of crippled  
     Version selector (Bug 123063) no useful info can be contributed
Comment 2 Rainer Bielefeld 2014-01-01 09:58:27 UTC
Created attachment 82194 [details]
Additional Info

Graphic file names, paths, ...
Comment 3 Raphael Bircher 2014-01-01 11:17:50 UTC
This means, it is a pre Apache OpenOffice issue.

I will try to investegate here
Comment 4 Raphael Bircher 2014-01-01 11:20:53 UTC
Rainer, do you have some informations about 3.2.1 or 3.2.0?
Comment 5 Rainer Bielefeld 2014-01-01 11:57:12 UTC
Was still ok with sever installation of "OOo 3.2.1 English UI / German locale [OOO320m18 (Build 9502)]" on  WIN7  Home Premium  (64bit) DE
Comment 6 Regina Henschel 2014-01-01 14:04:22 UTC
Created attachment 82195 [details]
next

The missing pictures are sc10617.png and sc10618.png. I see them in the source of OOo2.4.3. But I have currently no time to test, whether it is enough to put them into default_images/res.
Comment 7 Regina Henschel 2014-01-01 14:05:18 UTC
Created attachment 82196 [details]
previous
Comment 8 Raphael Bircher 2014-01-01 14:32:26 UTC
@Regina Yea, I just find out the same. I will test it now, and give Feedback
Comment 9 Rainer Bielefeld 2014-01-01 14:41:04 UTC
In Help under heading "Data Sources" (This section contains information on browsing and editing database tables.) I see 2 rather similar arrow symbols:
Previous record: vnd.sun.star.zip://file:%2F%2F%2FC:%2FAOO_Server%2F410%2F1554205_2014-01-01%2Fprogram%2F..%2Fshare%2Fconfig%2Fimages.zip/res/commandimagelist/sc_prevrecord.png
Next record: vnd.sun.star.zip://file:%2F%2F%2FC:%2FAOO_Server%2F410%2F1554205_2014-01-01%2Fprogram%2F..%2Fshare%2Fconfig%2Fimages.zip/res/commandimagelist/sc_nextrecord.png

May be some unification would be useful?
Comment 10 Raphael Bircher 2014-01-01 14:48:28 UTC
I realy ask myself who disrupt the icon sets, and with wich motivation?!

And why the heck we recognize this 3 years later???
Comment 11 Raphael Bircher 2014-01-01 14:53:04 UTC
@Rainer did you use Tango symboles? the sc_nextrecord.png is available at trunk, for default and industrial
Comment 12 Rainer Bielefeld 2014-01-01 15:55:02 UTC
@Raphael:
I use Galaxy, Tango theme is not available in my selector. As far as I know Help always shows Galaxy Icons in Help texts, independent from active Theme?
Comment 13 Regina Henschel 2014-01-01 20:07:54 UTC
I'm not sure, whether the dialog Edit > Footnote/Endnote itself has am image at all. For me it looks like a character is drawn onto the button. Perhaps we use no image in the help, but write this characters into the help? Or generate a new image, which fits to the actual buttons?

The same images are missing in the help for "Edit Fields", file helpcontent2/source/text/swriter/01/02140000.xhp. The other help file is helpcontent2/source/text/swriter/01/02150000.xhp 

LibreOffice uses different arrows on the buttons and the images lc06300.png and lc06301.png in the help. Those do not fit to the buttons in AOO.

I do not think that sc_nextrecord.png would be right, because the images in folder commandimagelist belong to .uno commands.

The current source for sc10618.png and sc10617.png is in ooo_custom_images/classic/classic_images.tar.gz
Comment 14 Raphael Bircher 2014-01-02 07:11:18 UTC
Just find out that we miss more icons. The whole 106*.png serie is missed. This are eight icons. I chack now where they are in use.
Comment 15 Raphael Bircher 2014-01-02 07:31:07 UTC
I just checked the other "missed" icons sc10620.png sc10621.png sc10627.png and sc10630.png. according opengrok they are no longer in use. The Icons ar not linked from any help file or source.

Prbabily someone cleaned up the icon set, and deleted some icon still in use.

Greetings Raphael
Comment 16 hdu@apache.org 2014-01-02 09:48:22 UTC
These (and related) images where removed with the dba33b CWS on Nov 6 in 2009 by fs@openoffice.org with the comment: "#i106671# those images are not needed anymore".
Comment 17 Matthias Seidel 2018-07-18 16:36:48 UTC
(In reply to hdu@apache.org from comment #16)
> These (and related) images where removed with the dba33b CWS on Nov 6 in
> 2009 by fs@openoffice.org with the comment: "#i106671# those images are not
> needed anymore".

sc10617.png and sc10618.png are really not used anymore.

My understanding is that AOO now uses blank buttons instead where left/right pointing triangles (from OpenSymbol font?) are drawn onto.

Since we need the graphics for the help I will recreate them in res/helpimg.
Comment 18 SVN Robot 2018-07-18 16:38:57 UTC
"mseidel" committed SVN revision 1836204 into trunk:
#i123941#
Comment 19 Matthias Seidel 2018-07-19 07:14:44 UTC
Fixed in trunk.

(Translations for help need to be updated)