Issue 123955

Summary: searching for char by format fails, and 'finds' wrong target
Product: Writer Reporter: TAB <TorrAB>
Component: editingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Normal    
Priority: P3 CC: elish, issues, rainerbielefeld_ooo_qa
Version: 3.4.0   
Target Milestone: ---   
Hardware: All   
OS: Windows, all   
See Also: https://issues.apache.org/ooo/show_bug.cgi?id=123063
Issue Type: DEFECT Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---
Attachments:
Description Flags
text to search
none
New Sample Document, bug irreproducible none

Description TAB 2014-01-03 04:11:44 UTC
Created attachment 82205 [details]
text to search

In searTNR.odt, search for 'e' with Match Case & Options>format: [Times New Roman, Italic] and:
** find, incorrectly: subscript e (not italic) in LineF, G;
** DO NOT find any 'e' italic that do exist in LineA, LineB, LineC.
	If the subscript e was 'found' in LineF, why was it not found in LineD, E or H?
	This looks like Bug 50083, which is 'CLOSED FIXED'...
Comment 1 Rainer Bielefeld 2014-01-03 07:59:43 UTC
I see the effect with  reporter's sample and "AOO 4.0.1   – German UI / German locale  [Rev. 1524958 2013-09-20 11:40:29]" on  German WIN7 Home Premium (64bit)", “historic”  4.0  User Profile used for all  predecessor versions.:

1. Open "text to search" Document
2. Menu 'Edit -> Find & Replace -> "e"; mach case; Times New Roman; Italic' 
   [Find All]
   > Bug: also finds in "LineF" first "ze", although "e" is not italic    :-(

But the problem seems to be related to some very particular things in the document, we will need some more research, for example why the second "ze" in
"LineF" will not be found:

11. Open attached "NewSample"
12. Menu 'Edit -> Find & Replace -> "e"; mach case; Times New Roman; Italic' 
    [Find All]
    > correctly only finds the lowercase "e" of "Ee"                      :-)
14. Now copy / paste above mentioned "ze" from reporter's sample document to 
    "NewSample" end of first line
15. Menu 'Edit -> Find & Replace -> "e"; mach case; Times New Roman; Italic' 
    [Find All]
    > correctly only finds the lowercase "e" of "Ee" 

Additional info:
----------------
(a) reported effect with reporter's sample already reproducible with OOo 1.1.5
(b)  Already reproducible with  Pre-3.4.0 (OOo 1.1.5), but because of crippled  
     Version selector (Bug 123063) no useful info can be contributed
(c) I will do some additional research wen BZ will work again
    

@TAB
Can you tell how to create a minimum sample document from the scratch?
Comment 2 Rainer Bielefeld 2014-01-03 08:34:54 UTC
Created attachment 82208 [details]
New Sample Document, bug irreproducible
Comment 3 Edwin Sharp 2014-01-03 09:15:29 UTC
As given in description.
AOO410m1(Build:9750)  -  Rev. 1552994
Rev.1552994
Win 7