Issue 124063

Summary: Extension "Oracle Report Builder" causes broken charts with source range "all"
Product: Calc Reporter: Andreas Säger <villeroy>
Component: editingAssignee: AOO issues mailing list <issues>
Severity: Normal    
Priority: P3 CC: issues, oooforum, rainerbielefeld_ooo_qa
Version: 4.1.0-dev   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Description Flags
Screenshot from broken chart in 4.1
Screenshot from broken chart in 3.4.1
Sample Document with Chart none

Description Andreas Säger 2014-01-20 23:19:25 UTC
Testing 4.1 with imported profile from 3.4.1 or reused profile from 4.0.1 all charts in my existing documents are broken. They show no data and the source range is "all".
This does not happen with a fresh profile created by 4.1.
This does not happen with new charts created in 4.1.
Comment 1 Andreas Säger 2014-01-20 23:22:29 UTC
Created attachment 82325 [details]
Screenshot from broken chart in 4.1
Comment 2 Andreas Säger 2014-01-20 23:23:15 UTC
Created attachment 82326 [details]
Screenshot from broken chart in 3.4.1
Comment 3 Andreas Säger 2014-01-20 23:38:00 UTC
Another test: I removed all extensions from 3.4.1 and let AOO4.1 import that profile, assuming that incompatible extensions may break the profile.
Indeed, the problem is gone.
Comment 4 Andreas Säger 2014-01-20 23:53:09 UTC
It's the Oracle Report Builder. Removing this extension from an imported or reused profile fixes the problem.
Comment 5 Rainer Bielefeld 2014-01-21 06:59:40 UTC
Created attachment 82328 [details]
Sample Document with Chart

NOT reproducible with attached sample document and  server installation of "AOO 4.1.0-Dev – German UI / German locale - [AOO410m1(Build:9750) - Rev. 1537508 - 2013-11-02]" on German WIN7 Home Premium (64bit)", own separate user profile Oracle Report builder 1.2.1 installed

We need more precise information, please
b) Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link; to attach a file to this 
  bug report, just click on "Add an attachment" right on this page.
  If you want to attach a test kit with multiple documents zip them into
  a single and attach the
f) add information 
  f4) concerning your Operating System (Version, Distribution, Language)
  f5) concerning your AOO version (with Build/revision ID if it's not a 
     public release) and localization (UI language, Locale setting)
  f6) AOO settings that might be related to your problems 
  f7) how you launch AOO and how you opened the sample document
  f8) Whether your problem persists when you renamed your user profile 
     (Quit Quickstart before!) before you launch AOO (please see
  f9) Whether that worked in former OOO / AOO Versions 
  f10) Report Builder Version
Comment 6 Andreas Säger 2014-01-21 10:19:38 UTC
I tried to attach one of my old user profiles which breaks charts including Rainer's sample. After removing the Report Builder from this profile, the problem is gone.
Unfortunately, the compressed profile is too big.

Answering Rainer's questions:
I run Ubuntu 12.04 (64 bit) and Java 1.7 (open jdk).
AOO410m1(Build:9750)  -  Rev. 1558977
2014-01-17_04:11:25 - Rev. 1559006
en-US, no lang packs yet, quick-starter disabled, started from launcher icon or command line.
Report builder version is 1.2.1
Yes, charting used to work with AOO 4.0.1 and all previous versions.
As I pointed out, this happens with 2 types of profiles:
a) The former 4.0.1 profile.
b) The 3.4.1 profile imported by the first-run wizard.
When I remove ORB1.2.1 the problem goes away. When I re-install ORB the problem is back again.
It does _not_ occur with a fresh profile created by AOO 4.1.0, with or without ORB 1.2.1
Comment 7 Andreas Säger 2014-01-21 12:40:49 UTC
The profile to (hopefully) reproduce the problem: (250 MB)
Comment 8 Andreas Säger 2017-01-12 14:58:33 UTC
Still a problem with AOO 4.1.3, ORB 1.2.1 and a brand new profile.
No charts in Calc. Charts are back after removing ORB.
Comment 9 Andreas Säger 2017-01-12 15:17:01 UTC
Uploaded my brand new profile with installed ORB to
Comment 10 oooforum (fr) 2017-12-31 17:41:05 UTC
(In reply to Andreas Säger from comment #8)
> Still a problem with AOO 4.1.3, ORB 1.2.1 and a brand new profile.
> No charts in Calc. Charts are back after removing ORB.

Please, could you update with last build 4.1.5 and re-try?
Comment 11 Andreas Säger 2018-01-01 12:55:37 UTC
Let's close this. Meanwhile I use OpenOffice with a new profile and the problem is gone.
Comment 12 oooforum (fr) 2018-01-01 13:36:24 UTC
According last comment