Issue 124229

Summary: OOO crashes after document recovery
Product: General Reporter: Dieter <didi.wirz>
Component: uiAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: elish, issues
Version: 4.0.1Keywords: needhelp
Target Milestone: ---   
Hardware: PC   
OS: Linux 64-bit   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Dieter 2014-02-13 14:45:14 UTC
When starting OO (by clicking on it or from terminal with soffice) "OO Document recovery" opens and wnts to recover some OO Calc document. When clicking okay (there is no other option) then OO crahes. 
From terminal I run with -norecovery and get normal operation, but when I start afterwards again you can see the errors below:

dw@UX31E:~$ soffice -norestore
dw@UX31E:~$ soffice 
**
GLib:ERROR:/build/buildd/glib2.0-2.38.1/./glib/gmain.c:3068:g_main_dispatch: assertion failed: (current->dispatching_sources == &current_source_link)


Fatal exception: Signal 6
Stack:
/opt/openoffice4/program/libuno_sal.so.3(+0x37b9a)[0x7f7595b47b9a]
/opt/openoffice4/program/libuno_sal.so.3(+0x37ccc)[0x7f7595b47ccc]
/opt/openoffice4/program/libuno_sal.so.3(+0x37d69)[0x7f7595b47d69]
/lib/x86_64-linux-gnu/libc.so.6(+0x36ff0)[0x7f759478dff0]
/lib/x86_64-linux-gnu/libc.so.6(gsignal+0x37)[0x7f759478df77]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x148)[0x7f75947915e8]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x4efdd)[0x7f7587e9bfdd]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_assertion_message+0x137)[0x7f7587eb93b7]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_assertion_message_expr+0x4a)[0x7f7587eb941a]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x17f)[0x7f7587e953ef]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x48708)[0x7f7587e95708]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x2c)[0x7f7587e957ac]
/opt/openoffice4/program/libvclplug_gtk.so(+0x23300)[0x7f7588f28300]
/opt/openoffice4/program/libvcl.so(+0x17c1f3)[0x7f7590df81f3]
/opt/openoffice4/program/libvcl.so(_ZN11Application7ExecuteEv+0x1b)[0x7f7590df73db]
/opt/openoffice4/program/libsofficeapp.so(+0x2d9ed)[0x7f75958b19ed]
/opt/openoffice4/program/libvcl.so(+0x17f5a5)[0x7f7590dfb5a5]
/opt/openoffice4/program/libvcl.so(_Z6SVMainv+0x1e)[0x7f7590dfb670]
/opt/openoffice4/program/libsofficeapp.so(soffice_main+0x9c)[0x7f75958d914c]
/opt/openoffice4/program/soffice.bin(main+0xb)[0x400f7b]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5)[0x7f7594778de5]
/opt/openoffice4/program/soffice.bin(__gxx_personality_v0+0xb9)[0x400eb9]
Comment 1 Edwin Sharp 2014-02-13 14:56:31 UTC
What Linux distribution?
Please attach Calc document.
Comment 2 Dieter 2014-02-13 15:36:01 UTC
dw@UX31E:~$ uname -a
Linux UX31E 3.11.0-14-generic #21-Ubuntu SMP Tue Nov 12 17:04:55 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

AKA Ubuntu 13.10 Saucy
Im runnin Gnome 3

Actully it's not a ods or xls-file, it's a simple ASCII *txt tab delimated. And, it's intact, I can open it e.g. in gedit. And, I am sorry, I cannot disclose this file to the community.

BTW: I found a workaround to fix the Problem: Accidently i moved the file to another folder, then in the message box a "do not recover" popped up, this solved the problem. Therefore I cannot reproduce the Error anymore.

But, this workaround dous not fix the bug.
Comment 3 Edwin Sharp 2014-02-13 15:38:37 UTC
OK, thank you.