Issue 124618

Summary: CRASH when open particular .pptx
Product: Impress Reporter: vladankudlac
Component: open-importAssignee: AOO issues mailing list <issues>
Status: CLOSED FIXED QA Contact:
Severity: Normal    
Priority: P3 CC: Armin.Le.Grand, elish, j.nitschke, rainerbielefeld_ooo_qa
Version: 4.1.0-betaKeywords: needmoreinfo
Target Milestone: ---   
Hardware: PC   
OS: Windows 7   
See Also: https://issues.apache.org/ooo/show_bug.cgi?id=121356
https://issues.apache.org/ooo/show_bug.cgi?id=119854
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
2nd page of original file none

Description vladankudlac 2014-04-07 13:14:06 UTC
When I try to open attached file, it crashed and it doesn't say any reason. Libre Office opens it normally. Others presentations are open correctly.
Comment 2 Edwin Sharp 2014-04-07 14:21:33 UTC
link in comment 1 empty
Comment 3 Oliver-Rainer Wittmann 2014-04-07 14:23:26 UTC
(In reply to vladankudlac from comment #1)
> Presentation
> https://www.dropbox.com/s/32xer34pv2l7apw/
> Integrovan%C3%BD%20dopravn%C3%AD%20syst%C3%A9m.pptx

I can not download the sample document.
DropBox tells me (translated from German) "nothing available - the file has been deleted or moved."
Comment 4 j.nitschke 2014-04-07 14:27:35 UTC
Created attachment 83116 [details]
2nd page of original file

reproducible with AOO 4.1 beta
file doesn't open (no progress shown)
crash when trying to open read only

opens with AOO 3.4.1

created sample from 2nd page of the dropbox file

looking for dups
Comment 5 Armin Le Grand 2014-04-07 15:09:32 UTC
No crash here on Win7 on trunk (AOO410m14(Build:9760)  -  Rev. 1583418
2014-03-31 13:09:56 (Mon, 31 Mar 2014)).
Also loads fine on my latest beta build (AOO410m15(Build:9761)  -  Rev. 1583567). 

This sound similar to one of the fixed tasks on the track from beta to release version.

Problem is more that there are 18 undo actions in the undo stack (in both versions) and that it crashes when I trigger UNDO. Import should *not* create undos at all, maybe a general error in the pptx import (...?)
Comment 6 j.nitschke 2014-04-07 15:43:05 UTC
> No crash here on Win7 on trunk (AOO410m14(Build:9760)  -  Rev. 1583418
> 2014-03-31 13:09:56 (Mon, 31 Mar 2014)).
> Also loads fine on my latest beta build (AOO410m15(Build:9761)  -  Rev.
> 1583567). 
yes, crash on official Beta Rev. 1573601
loads fine on trunk Rev.1585331

> This sound similar to one of the fixed tasks on the track from beta to
> release version.
> 
> Problem is more that there are 18 undo actions in the undo stack (in both
> versions) and that it crashes when I trigger UNDO. Import should *not*
> create undos at all, maybe a general error in the pptx import (...?)
saving file as .ppt (with MS PowerPoint) and opening file with Beta works fine

@Armin Le Grand 
could you set DUP? i can't find the issue
Comment 7 Rainer Bielefeld 2014-04-07 17:55:56 UTC
With a quick search I found other bug reports with problem "pptx opens with items in undo stack":
"Issue 121356 - Crash when loading pptx file second/third time after deleting user profile"
"Issue 119854 - [From Symphony] Particular .pptx with table opens with items in Undo-Stack"

I do not mark this one and as DUP Issue 121356 because I can't tell whether the undo issue really is the reason for a crash.
Comment 8 Edwin Sharp 2014-04-07 18:49:33 UTC
No crash when opening attachment 83116 [details]
AOO410m15(Build:9761)  -  Rev. 1583666
2014-04-01 13:50 - Linux x86_64
Debian
Comment 9 vladankudlac 2014-04-07 19:21:52 UTC
I am sorry, the link doesn't work for me now too, but I can open the presentation now. Maybe the reboot of computer solved it.