Issue 124660

Summary: PDF/A-1a export crashes on certain documents
Product: Writer Reporter: jstaerk <jstaerk>
Component: save-exportAssignee: AOO issues mailing list <issues>
Status: CLOSED DUPLICATE QA Contact:
Severity: Normal    
Priority: P3 CC: j.nitschke
Version: 4.0.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Sample file which crashes OO.o in PDF/A export none

Description jstaerk 2014-04-11 08:29:24 UTC
Created attachment 83169 [details]
Sample file which crashes OO.o in PDF/A export

Steps to reproduce:
- open the attached file 
- select File|Export as PDF, 
- check the PDF/A-1a checkbox
- click export button, 
- select a filename, 
- click save, 

Result:
OpenOffice.org will crash (Windows reports "Openoffice.org funktioniert nicht mehr", i.e. "Openoffice.org funktioniert nicht mehr" does not work any more with the only possibility to close the software) and the PDF-file is missing. When Openoffice is started the next time, a document recovery will pop up. 

Expected Result:
A PDF/A-1a export of the document and OpenOffice continuing to run.

Environment:
Happens on a german Win7 64 bit with a OpenOffice.org 4.0.1.
You can get the font (Liberation Sans) used in the document from https://fedorahosted.org/liberation-fonts/ .

Successless reproduction using:
The following things work work flawlessly:
- exporting the attached document to ordinary PDF (non "PDF/A-1a") documents
- in general exporting documents to PDF/A-1a that contain text fields, 
- documents containing the font (Liberation Sans)

Business justification:
I need the PDF/A-1a export for this document is because it is my main invoice template and my accounting software (Gnuaccounting) integrates openoffice to create PDF/A-1a and then uses Apache PDFbox to "upgrade" to to PDF/A-3a which is then used as basis for Gnuaccounting's Zugferd export, which produces the file I sent to my customers and which works with all documents from which a PDF/A-1a can be exported.
Comment 1 j.nitschke 2014-04-11 08:54:30 UTC
Comment on attachment 83169 [details]
Sample file which crashes OO.o in PDF/A export

I suspect a duplicate of Issue 123409 - Images in background cause crash when saving to pdf/a

In your sample the text frame "Rahmen2" wrap set to background (de: im Hintergrund).
Could you try and change it to wrap through (de: Durchlauf) and try to export again.

if it works it's a duplicate of Issue 123409 and is fixed in the next version of AOO
Comment 2 jstaerk 2014-04-11 09:04:02 UTC
Hi,

the other way around, it IS "Durchlauf"  wrap through but when I change it to "Hinter" (in Background?) it works. Thanks!
Comment 3 Oliver-Rainer Wittmann 2014-04-11 09:18:58 UTC
due to the given feedback I am marking this issue as a duplicate.

@jstaerk: The defect should be solved in AOO 4.1.0. You can verify it in the recent AOO 4.1.0 RC (release candidate) or in AOO 4.1.0 Beta

*** This issue has been marked as a duplicate of issue 123409 ***
Comment 4 jstaerk 2014-04-11 09:31:19 UTC
Apologies, correction wrap mode "Hinter" is not "in Background" but sth. like "behind" but there is a checkbox "in Background" and it also works when I keep the "Durchlauf" and I only uncheck the checkbox.