Issue 124748

Summary: Past of text and other formats into a text box doesn't work
Product: Impress Reporter: Peter Bluewin <peter.bluewin>
Component: editingAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Normal    
Priority: P3 CC: elderthing, rainerbielefeld_ooo_qa
Version: 4.1.0-betaKeywords: needmoreinfo
Target Milestone: ---   
Hardware: PC   
OS: Windows 7   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Peter Bluewin 2014-04-27 10:57:01 UTC

    
Comment 1 Peter Bluewin 2014-04-27 11:07:13 UTC
Operating system environment:
Hardware: Lenovo H520S, Graphic: Intel HD Graphic 1000 (GT1)
Operating system: Windows 7 Home Premium 64 bit

Test of OO 4.1.0 beta
Part: Impress
Procedure:
1. create new blank formular
2. select "title form"
3. open Notepad++, create new blank page, insert text like "text", copy text
4. paste data into text-page of impress 
5. Nothing happens
Comment 2 Rainer Bielefeld 2014-04-30 06:10:43 UTC
NOT reproducible with "AOO 4.1.0 RC4 – German UI / German locale [AOO410m18(Build:9764)  -   Rev. 1589052 2014-04-22 11:43:54]" on German WIN7 Home Premium (64bit)", “historic” 4. User Profile used for all predecessor versions

I am not sure whether I understand the problem. My test.

1. From AOO Start center open new Impress document without using wizard
   > Slide with Title and Text input box appears
2. Open "EditPad Lite" text editor -> Type "Text", -> Select text by 
   doubleclick - <control+c> for copy
3. Double click big "Add Text" field on impres slide
   > Edit mode, caret flashes
4. <control+v> for paste
   > string "Text" appears

Additional info:
----------------
(a) Same fine result with WIN text editor (Notepad) and SynWrite 
(b) Also works fine for title input box on Impress slide

@Peter Bluewin:
Thank you for your feedback – unfortunately important information we will 
need to reproduce your problem is missing.
Please add all information requested in following:
a) Write a meaningful Summary describing exactly what the problem is
b) Attach a sample document (your new presentation) or refer to an existing 
   sample document in an other Bug with a link; to attach a file to this 
   bug report, just click on "Add an attachment" right on this page.
   If you want to attach a test kit with multiple documents zip them into
   a single testkit.zip and attach the  testkit.zip
c) Contribute a document related step by step instruction containing every 
   key press and every mouse click how to reproduce your problem 
d) Attach screenshots with comments if you believe that that might explain the 
   problem better than a text comment. Best way is to insert your screenshots
   into a DRAW document and to add comments that explain what you want to show
e) if possible contribute an instruction how to create a sample document 
   from the scratch
f) add information 
   f1) what EXACTLY is unexpected. 
   f2) Installed extensions, other software running in parallel (for
       Example "TightVNC" interferes with WIN Clipboard)
   f3) concerning your PC (video card, ...)
   f4) concerning your Operating System (Version, Distribution, Language)
   f5) concerning your AOO version (with Build/revision ID if it's not a 
      public release) and localization (UI language, Locale setting)
   f6) AOO settings that might be related to your problems 
   f7) how you launch AOO and how you opened the sample document
   f8) Whether your problem persists after you have renamed your user profile 
     (Quit Quickstart before!) before you launch AOO (please see   <https://wiki.openoffice.org/wiki/Documentation/How_Tos/Handling_the_OpenOffice.org_User_Profile>
     <https://wiki.documentfoundation.org/User_Profile#Mac_OS_X>
   f9) Whether that worked in former OOO / AOO Versions 
   f10) whether (and how) a competitor's software (MSO, LibreOffice, ...)
        fulfills your needs
   f11) Also other Text Editors, Websites, whatever affected?

Please do not cite these hints in your reply, but cite the items like:
f7): Desktop-icon for soffice.exe / AOO File menu -> Open
Comment 3 elderthing 2014-06-09 00:23:02 UTC
This does not seem to be an issue in Apache Open office 4.1.0 under Windows 8. 

I tried pasting text from both Libre Office and Notepad, and neither had any unexpected behaviour.

A screenshot or further description would help as indicated by Rainer's post. Dialogue windows can interrupt pasting, could that have been the issue?