Issue 124853

Summary: Pasting into "Find" field pastes into "Input Line" and inserts
Product: General Reporter: Brennan Novak <hi>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Normal    
Priority: P3    
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: Mac   
OS: Mac OS X, all   
Issue Type: DEFECT Latest Confirmation in: 4.1.0
Developer Difficulty: ---
Attachments:
Description Flags
Screenshot highlighting find & input fields none

Description Brennan Novak 2014-05-08 11:32:56 UTC
Upon trying to paste a string of text from my Mac OS clipboard into the "Find" field, OpenOffice instead pastes my text into the "Input Line" and automatically inserts the text into the document on the current cell. In my attached image you can clearly see that the the "Find" field is "focused" by the app. There appears to be absolutely no way to get the "Find" field to allow me to input text except for manually typing it out.

This is completely incorrect UI / UX behavior, as a focused input field SHOULD always be where a paste command goes to. In this particular case it is doubly troublesome as my clipboard text was inserted into the document, then when I manually entered my query into the "Find" field it found the incorrectly inserted data.
Comment 1 Brennan Novak 2014-05-08 11:33:46 UTC
Created attachment 83357 [details]
Screenshot highlighting find & input fields
Comment 2 mroe 2014-05-16 09:13:46 UTC
I can confirm this issue also for OOo versions (at least 3.3) under MacOS 10.8.2 for all modules.