Issue 125093

Summary: NO Spellcheck
Product: General Reporter: Andrew <andrewwilson>
Component: spell checkingAssignee: AOO issues mailing list <issues>
Status: CLOSED DUPLICATE QA Contact:
Severity: Major    
Priority: P3 CC: philip, stevemcgrew
Version: 4.1.0   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Spell check Not Picking up Word "Journey" or Error "Jorney" . . I presume lots of Others too :-/ none

Description Andrew 2014-06-13 14:54:43 UTC
Created attachment 83547 [details]
Spell check Not Picking up Word "Journey" or Error "Jorney" . . I presume lots of Others too :-/

Spellchecker is not Picking up errors in any App, Writer or Sheets ..! It was before latest update to 

AOo 4.1.0 
AOO410m18(Build:9764)  -  Rev. 1589052
2014-04-22 11:43:54 (Di, 22 Apr 2014)

No Words appear to be in Dictionary(s) .. O.o
Comment 1 Philip Belben 2014-06-27 19:11:37 UTC
I have a problem that looks related.

Earlier this month (June 2014) I opened a document in OpenOffice Writer to find that every word was marked as a spelling error.

This was with OpenOffice 4.0.1, so today I upgraded to 4.1.0.  Problem persists.

I tried re-installing the English Dictionaries extension.  I consistently get the error message:

C:\Users\User\AppData\Roaming\OpenOffice\4\user\uno_packages\cache\uno_packages\svj13c.tmp_\dict-en.oxt does not exist.

This is true.  There is no ...\svj13c.tmp_ subdirectory there at all.  The only one is ...\svlm9d.tmp_ and this contains only the German dictionary.  Copying the English dictionary extension in there also didn't help.  However, if I set the language to German, and type some German, it checks the spelling correctly and flags only words that are not correct German words.

Time for more drastic measures.  I created the svj13c.tmp_ subdirectory, put the downloaded extension in there, and ran it from there.  Up came OpenOffice extension manager, asking would I like to replace the older extension of the same name with this one.  Yes please!  It claimed a successful installation, and gave me a list of English spelling conventions available to me ... but the bug remains.  If I select UK English, all words are underlined in red.  Likewise with Australian English - I haven't tried any others - but German still works.

In case it is not clear from the filename in the error message, this is a Windows 7 system.  In case it matters, my default languages is everywhere British English.

Incidentally, can we have a facility to copy text from the error dialogue box in order to paste it into the bug reprt?
Comment 2 Ariel Constenla-Haile 2014-06-27 20:02:22 UTC
Try removing the extension folders in your user profile (note that will remove all the extension you have installed):

- close OpenOffice, including the system tray icon (known as the "Quickstarter")
- remove these folder:

C:\Users\User\AppData\Roaming\OpenOffice\4\user\uno_packages\
C:\Users\User\AppData\Roaming\OpenOffice\4\user\extensions\

- restart OpenOffice

If this does not solve your problem, then try resetting the whole user profile, removing/renaming 
C:\Users\User\AppData\Roaming\OpenOffice\4\user
Comment 3 Philip Belben 2014-06-29 12:57:45 UTC
On a clean session (well, fairly clean - this being Windows it took me three attempts to boot my PC this afternoon!) I tried the first of Ariel's remedies - removed the uno_packages and extensions directories.  Started OpenOffice Writer, and English spelling check was working.  Installed the German dictionary, re-started OpenOffice, and now I have both English and German spelling checking working correctly.

Many thanks!  I was horribly afraid I'd end up writing my next essay in Microsoft Word :-(

Incidentally, yesterday (before I tried the remedy) I noticed that the spelling check was working correctly in OpenOffice Calc.
Comment 4 Steve McGrew 2014-09-18 18:08:08 UTC
Having s similar issue in Win7, Oo 4.10 this morning every single word in the book I'm writing was marked as misspelled. Upgraded to Oo 4.11, problem persisted. Uninstalled Oo when I discovered that a chapter name written in Thai changed to boxes, my backup copy of the document was the same. Reinstalled 4.10, both problems persist.

Cannot remove files suggested in earlier comment, W7 has them unavailable in File Manager.

Maybe I should install Linux and try the Linux version of Oo?
Comment 5 Ariel Constenla-Haile 2014-09-19 03:51:38 UTC
(In reply to Steve McGrew from comment #4)
> Cannot remove files suggested in earlier comment, W7 has them unavailable in
> File Manager.

The user directory is usually a hidden folder.
Try to get the full path from the Options dialog (Tools - Options - OpenOffice - Paths), and type the path directly in the address bar of the file explorer.
Alternatively you can configure the file manager to show hidden files.

*** This issue has been marked as a duplicate of issue 121930 ***