Issue 125497

Summary: An ability to hide the zoom slider
Product: General Reporter: Michael <shion>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CLOSED DUPLICATE QA Contact:
Severity: Normal    
Priority: P3 CC: rb.henschel, shion
Version: 4.1.0Keywords: usability
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: 4.1.0
Developer Difficulty: ---

Description Michael 2014-08-24 00:52:09 UTC
It would be great, if there was some way to hide the zoom slider.

I encountered the same problem with the zoom slider as the authors of these issues:
https://issues.apache.org/ooo/show_bug.cgi?id=116700
https://issues.apache.org/ooo/show_bug.cgi?id=116958
https://issues.apache.org/ooo/show_bug.cgi?id=113828

This problem is likely to happen, if you to scroll to the right often using the horizontal bar and work fast. The unexpected zoom changes are very annoying...

While adding an ability to hide the zoom slider would not solve the core problem, it may be a feasible workaround for these, who rarely use zoom. Also, one can access zoom function using CRTL + mouse wheel and a button (or menu).
Comment 1 mroe 2014-08-24 07:02:25 UTC
As workaround you can disable the whole statusbar.

*** This issue has been marked as a duplicate of issue 116700 ***
Comment 2 Michael 2014-08-24 10:59:17 UTC
mroe, I tried it already, but I don't see this as a viable workaround:
If I hide the status bar, I lose progress status on calculation & saving as well as the sum info.

Also, the only related issue now is P5. Are you suggesting that people, who have a problem with zoom slider's behavior, work without the status bar till this P5 is fixed? Seeing that the first of the related issues was reported in 2010, it doesn't look like it'll ever be fixed...

Also, I see another reason to implement an ability to hide zoom slider - simply because we can already hide almost everything, why not slider?

Please consider re-opening this issue, or at least increase Importance of https://issues.apache.org/ooo/show_bug.cgi?id=116700
Comment 3 Regina Henschel 2014-08-24 12:21:21 UTC
Michael, you can hide the zoom slider only. Copy the file "status.xml" from <installation path>/share/config/soffice.cfg/modules/swriter/statusbar to the corresponding folder in your OpenOffice "user" folder. Open the copied file in an editor and "comment out" the line, which is responsible for the zoom slider:
...
 <statusbar:statusbaritem xlink:href=".uno:Size" statusbar:align="left" statusbar:autosize="true" statusbar:ownerdraw="true" statusbar:width="129"/>
 <statusbar:statusbaritem xlink:href=".uno:ViewLayout" statusbar:align="center" statusbar:ownerdraw="true" statusbar:width="63"/>
<!--
 <statusbar:statusbaritem xlink:href=".uno:ZoomSlider" statusbar:align="center" statusbar:ownerdraw="true" statusbar:width="130"/>
 -->
 <statusbar:statusbaritem xlink:href=".uno:Zoom" statusbar:align="center" statusbar:width="35"/>
</statusbar:statusbar>

If you need help in this, ask in forum or mailing list.
Comment 4 Michael 2014-08-24 13:01:42 UTC
Thank you very much, Regina, it worked.

In case of Calc, the folder is:
...\share\config\soffice.cfg\modules\scalc\statusbar

The relevant line is:
<statusbar:statusbaritem xlink:href=".uno:ZoomSlider" statusbar:align="center" statusbar:ownerdraw="true" statusbar:width="140"/>
Comment 5 Ariel Constenla-Haile 2014-08-24 23:19:45 UTC
This request falls into "Allow to customize the status bar" (as is not a dup of issue 116700), feature available in OOo 1, but not implemented since OOo 2; there is a bug report, but I can't find it right now.