Issue 12587

Summary: Inserting/editing arbitrary text objects in chart
Product: General Reporter: vincentpatrick <vap>
Component: chartAssignee: kla <thomas.klarhoefer>
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: IngridvdM, issues, pagalmes.lists, tony.galmiche.ooo
Version: 3.3.0 or older (OOo)Keywords: rfe_eval_ok, usability
Target Milestone: ---   
Hardware: PC   
OS: Windows 2000   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 90135    
Attachments:
Description Flags
TCS for ChartShapes none

Description vincentpatrick 2003-03-22 10:32:50 UTC
It would be useful to be able to insert text and arrows within a chart, in order
to allow explanatory notes of the data presented.
Comment 1 kla 2003-03-27 12:34:56 UTC
I take it.
Comment 2 kla 2003-03-27 12:36:26 UTC
Hm, the second part sounds good.
Hi Bettina,
one for you.
tk
Comment 3 eric.savary 2003-04-16 15:29:58 UTC
Set to "NEW"
Comment 4 bettina.haberer 2004-11-29 18:09:29 UTC
Reassigned to Ingrid.
Comment 5 IngridvdM 2005-04-29 11:32:34 UTC
If the available standard text fields (like diagram title, axis title, data
point labels) are not sufficient there should be an easy way to create
additional text elements to support extra description of the represented data.
This text objects need to be modifiable after creation.

Workaround: At the moment you can copy and paste the title to get an extra text
object. But you cannot edit the new text object anymore, so do the editing
before copy.

->Vincent: I do consider having arrows less importand to text objects. Therefroe
I would like to concentrate on text objects only within this issue and changed
the summary like that. Would you mind to create an additional Issue for arrows
only. Thanks in advance.
Comment 6 IngridvdM 2005-04-29 11:43:15 UTC
*** Issue 20343 has been marked as a duplicate of this issue. ***
Comment 7 IngridvdM 2007-11-14 13:47:52 UTC
*** Issue 83608 has been marked as a duplicate of this issue. ***
Comment 8 pagalmes.lists 2008-06-09 10:31:38 UTC
*** Issue 90499 has been marked as a duplicate of this issue. ***
Comment 9 IngridvdM 2008-07-22 14:21:17 UTC
reset to new
Comment 10 IngridvdM 2009-03-02 09:51:45 UTC
@tbe, please implement this feature. Thanks! :-)
Comment 11 daniel.rentz 2009-07-21 10:50:28 UTC
Import of embedded shapes from BIFF5, BIFF8, MSOOXML committed (code modules
"sc" and "oox").
Test documents:
http://sc.openoffice.org/testdocs/index.html -> Chart Settings and Formatting ->
Embedded drawing shapes -> BIFF5/BIFF8/XML2003/XML2007
Comment 12 daniel.rentz 2009-08-06 15:00:08 UTC
export to BIFF8 done too.
Comment 13 thomas.benisch 2009-11-10 10:25:32 UTC
set target OOo 3.3
Comment 14 thomas.benisch 2009-11-11 11:25:28 UTC
fixed in CWS chartshapes
Comment 15 thomas.benisch 2009-11-11 11:26:49 UTC
The specification is available at
http://specs.openoffice.org/chart/ChartDrawingObjects.odt
Comment 16 thomas.benisch 2010-01-18 11:29:15 UTC
TBE->KLA: Please verify in CWS chartshapes.
Comment 17 kla 2010-02-01 10:44:11 UTC
Created attachment 67499 [details]
TCS for ChartShapes
Comment 18 kla 2010-02-01 10:50:59 UTC
verified in cws chartshapes
Comment 19 kla 2010-08-04 09:57:21 UTC
Seen ok -> closed