Issue 126440

Summary: Editing of Formula TRANSPOSE impossible
Product: Calc Reporter: udippel <udippel>
Component: programmingAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Normal    
Priority: P5 (lowest) CC: oliver.brinzing, rb.henschel
Version: 4.1.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Description Flags
TRANSPOSE cannot be edited nor replaced without a prior deletion none

Description udippel 2015-08-03 08:20:28 UTC
Created attachment 84851 [details]
TRANSPOSE cannot be edited nor replaced without a prior deletion

A vertical sequence can be TRANSPOSEd, but the formula as such cannot be edited:
"You cannot only change part of an array"

While this is true if I only change a part of the array, it still isn't possible (and the same message appears) when I change the whole array.

Example: attachment shows 5 values transposed. Marking these 5, it still is impossible to modify the range, e.g. from A3:A7 to A2:A6. 

It is even impossible to mark the array of 5 transposed cells, and call TRANSPOSE again, marking A2:A6. It still gives the same message.

The only way is to clear the formula for all fields, and then insert a new one.
Comment 1 Oliver Brinzing 2015-08-03 16:48:04 UTC
have you tried:

- open sample spreadsheet
- select B15:F15
- press F2
- change range: A2:A6
- press strg+shift+enter
Comment 2 udippel 2015-08-03 19:03:46 UTC
No, I haven't.

But your comment has at least amused me, thanks. Really.
What's wrong with editing like any other formula?

No, I haven't tried. I confess. I even believe you that it might work, though it deserved a nomination to the most obfuscated command sequence. If it worked. 
And I'd still consider it a bug, since obfuscated code is not what we all want, plus the impossibility to replace this function with any other function by just 'insert [modified] function.
Comment 3 Regina Henschel 2015-08-03 20:06:24 UTC
1. Set the cursor on any cell of the array, which is the result of the formula.
2. Press Ctrl /, where / is the division key on the numpad. That selects the whole array-formula. If you haven't got a numpad, you can customize your office to use another shortcut. It is the command "Select Array Formula" in the category "Edit".
3. Click into the input line to edit the formula.

In some cases the output of an array-formula has empty cells. That does not matter, if you use Ctrl /, but you will not notice it, when you try to mark the array by dragging the mouse.

For more help on array formulas read the topic "Array Functions" in the build-in help. Use tab "Find" and check "Complete words only" and "Find in headings only" to quickly access that topic.
Comment 4 udippel 2015-08-04 12:33:24 UTC
'Not an issue' is daring, I have to say. That's how bugs resurrect as features ... .;-)
"Won't fix" wouldn't be much better, but more realistic in the light of the explanation.

1. The error message is still in error: When modifying a whole array, the message "You cannot only change part of an array" is wrong, because that's not what the user wants (as long as she marks the whole array).

2. It is illogical that one can mark some cells, insert a function. And when one marks the same cells again, one cannot insert another function. 

Even for the lazy people, seemingly like myself, who don't read the whole manual before using an application, the error messages and the behaviour ought to be correct and logic.
Comment 5 udippel 2015-08-04 12:48:07 UTC
Sorry, was too fast. In the end, I tried your suggestion, #3, and it does exactly not work.
Moving the cursor into one of the cells, Ctrl+/ actually marks the whole formula and the rectangle around the original (source) cells. It is possible to move that rectangle, it is possible to change the values to A2:A6, true. But then: "You cannot only change part of an array".

As a normal user I can't set it back to anything but UNCONFIRMED and that's what I did. 

(You could at least have *tried* on my simple example file before marking it 'not an issue'.)
Comment 6 udippel 2015-08-04 12:58:27 UTC
Okay, last one for now: (so everyone including myself hope!) #2 is correct. *That* works. And, yes, 'Enter' only doesn't. That does make it a contender for the most ridiculous obfuscated user interaction of any software that states it wants to enlarge its user base. :-(

And I hope I don't have to file another bug: because it is impossible to copy that formula. At least not with the method according to #2, I tried my best. It is possible to *copy*, but it does not paste as formula into a range of marked cells.