Issue 126562

Summary: Repeated loaded records on large editable tables or queries
Product: Base Reporter: kbarber
Component: codeAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Normal    
Priority: P5 (lowest) CC: kbarber
Version: 4.1.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows 10   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
See the Large Table table and query for an example of a large editable table/query. none

Description kbarber 2015-09-30 03:35:08 UTC
For this glitch to occur, your table/query must have the following properties:
-You can edit the data of the (underlying) table after double-clicking on your table/query to open it.
-There are too many records to display. (e.g. At the bottom left when you double-click to open your table/query, it should say something like "Records 1 of 74*" (* indicates that there are more records)

Double-click on your table/query to open it. Scroll down so that more but not all of the records load. When you scroll back up, one of the loaded records will appear in the place of your first records, repeated. Scrolling back down doesn't solve this. Closing and reopening the query seems to solve this.

Note that it doesn't matter how you scroll down. I've tried PgDn and changing the "1" of "Records 1 of 74*".

If you edit a repeated glitch record, you are editing the record that it displays and not the record at that same row. This means that if you make a change to one glitch record and a change to another glitch record, your last change is the one that is saved.

I've tried this on Windows 7 and Windows 10.

I hope that I was specific enough.
Comment 1 kbarber 2015-09-30 03:39:21 UTC
Created attachment 84970 [details]
See the Large Table table and query for an example of a large editable table/query.