Issue 126597

Summary: Object Properties dialog contains "JRE Required" trap
Product: General Reporter: orcmid <orcmid>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CLOSED DUPLICATE QA Contact:
Severity: Major    
Priority: P5 (lowest) CC: oooforum, pescetti, villeroy
Version: 4.1.1Flags: pescetti: 4.1.2_release_blocker-
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Object properties with JRE required message at the Macro taab none

Description orcmid 2015-10-20 00:01:27 UTC
Created attachment 85054 [details]
Object properties with JRE required message at the Macro taab

In Writer and elsewhere that OLE-embedded Objects are allowed, the "Object" property sheet Macro tab contains a JRE-Required trap.  As soon as the tab is selected, there is a warning message that

   JRE Required
         OpenOffice requires a Java runtime environment (JRE) to 
         perform this task.  Please install a JRE and restart
         OpenOffice.

The OK button on this dialog clears it momentarily and then the same dialog reappears.  There is no way to close either the dialog or the open application.
There is no way to save any work at this point.

The only way I found to proceed is to use the Windows Task Manager to close OpenOffice, restart/shutdown the Windows desktop, or power-down the computer.

This is related to but not the same incident as #122108 #79125 #121245 #122185 #74940 #15147 #45709
Comment 1 oooforum (fr) 2015-10-20 07:18:57 UTC
A workaround will be to have this dialog with Macro tab disabled by default.
Before loading, testing the availability of JRE.
If yes, enable the Macro tab.
Comment 2 Andreas S├Ąger 2015-10-20 10:19:03 UTC
Could be a duplicate of https://bz.apache.org/ooo/show_bug.cgi?id=86541
No, you do not need any JRE to assign macros.
Comment 3 Andrea Pescetti 2015-10-21 07:43:57 UTC
As confirmed by orcmid on dev list: this was accidentally flagged as potential 4.1.2 blocker. Rejecting as blocker.
Comment 4 orcmid 2015-12-12 15:48:04 UTC
Note, the specific example of a JRE trap here is a duplicate of Issue 55977 which has been around since 2005.

This is also part of a generic situation (and Issue 55977 has a comment pointing to the likely offending code).

*** This issue has been marked as a duplicate of issue 55977 ***
Comment 5 orcmid 2015-12-12 15:49:49 UTC
(In reply to orcmid from comment #4)
> Note, the specific example of a JRE trap here is a duplicate of Issue 55977
> which has been around since 2005.
> 
> This is also part of a generic situation (and Issue 55977 has a comment
> pointing to the likely offending code).
> 
> *** This issue has been marked as a duplicate of issue 55977 ***
Note the other related issues,

Issue 122108
Issue 79125
Issue 121245
Issue 122185
Issue 74940
Issue 15147
Issue 45709