Issue 127315

Summary: Starting application with error message
Product: Writer Reporter: Mechtilde <mechtilde>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CLOSED FIXED QA Contact:
Severity: Major    
Priority: P2 CC: damjan, jim, josef.latt, knmc, mseidel, oooforum, pedlino, pescetti, petko, truckman, yury.tarasievich
Version: 4.2.0-devKeywords: regression
Target Milestone: 4.2.0   
Hardware: PC   
OS: Linux, all   
See Also: https://bz.apache.org/ooo/show_bug.cgi?id=127651
https://bz.apache.org/ooo/show_bug.cgi?id=127707
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 125147    
Issue Blocks:    

Description Mechtilde 2017-02-05 11:06:40 UTC
follow up #125147

I tested the nightly build 4.2 from 04.02.2017
If I open a random text document I get first the message "general error"
If I open a random calc document I get first the message "Not all attributes could be read"
this doesn't happen with the other moduls
what can I do to give you more informatione about it
I tested it under Debian 9 (Stretch), XFCE4.12 64 bit
Comment 1 Matthias Seidel 2017-02-05 14:30:55 UTC
I can confirm this on Ubuntu 16.04.1 64bit with AOO 4.2.0 nightly build from 04.02.2017.

I get this error when saving a text document:

Error saving the document Untitled 1:
General Error

Nevertheless the document has been saved. By opening the same document I get:

General Error

By confirming with OK the document is loaded.

I get the same error when opening a document that was created with AOO 4.1.3.
Comment 2 damjan 2017-02-06 16:36:36 UTC
Latest trunk built from source, works just fine on Ubuntu 16.04, 32 bit. It might be the bitness, or a difference in the build options.
Comment 3 Matthias Seidel 2017-04-26 20:22:05 UTC
I get the same error message with Ubuntu 16.04.2 (32bit) with latest 4.2.0 nightly build from buildbot (26.04.2017), de and en-US.
Comment 4 Matthias Seidel 2017-05-15 16:14:53 UTC
(In reply to damjan from comment #2)
> Latest trunk built from source, works just fine on Ubuntu 16.04, 32 bit. It
> might be the bitness, or a difference in the build options.

Can you post your build options?

The build options for the buildbots can be seen here:

https://svn.apache.org/repos/infra/infrastructure/buildbot/aegis/buildmaster/master1/projects/openofficeorg.conf
Comment 5 Jim Jagielski 2017-10-17 19:47:02 UTC
With macOS, the issue was triggered when the build found, and used, the non-system libxml library. This was done via too-eager searching for libraries via expat. Trying forcing libxml and possible limxslt
Comment 6 jolatt 2018-01-28 08:02:48 UTC
With this build AOO420m1(Build:9800)  -  Rev. 1822069 I have no error messages.

OS: Windows 7 in Virtualbox
Comment 7 Mechtilde 2018-01-28 18:00:03 UTC
I tested it with the actual dev build (Rev.:1821959) which is the latest for Linux 64 bit 2018-01-23.

So I have to wait for a newer build.
Comment 8 jolatt 2018-01-29 09:30:31 UTC
(In reply to jolatt from comment #6)
> With this build AOO420m1(Build:9800)  -  Rev. 1822069 I have no error
> messages.
> 
> OS: Windows 7 in Virtualbox

Same with Windows 10 64 bit.
Comment 9 Matthias Seidel 2018-01-29 16:06:22 UTC
(In reply to jolatt from comment #8)
> (In reply to jolatt from comment #6)
> > With this build AOO420m1(Build:9800)  -  Rev. 1822069 I have no error
> > messages.
> > 
> > OS: Windows 7 in Virtualbox
> 
> Same with Windows 10 64 bit.

This is specific for Linux, there is no need to test it on Windows... ;-)
Comment 10 Keith N. McKenna 2018-01-29 17:17:45 UTC
(In reply to Matthias Seidel from comment #9)
> (In reply to jolatt from comment #8)
> > (In reply to jolatt from comment #6)
> > > With this build AOO420m1(Build:9800)  -  Rev. 1822069 I have no error
> > > messages.
> > > 
> > > OS: Windows 7 in Virtualbox
> > 
> > Same with Windows 10 64 bit.
> 
> This is specific for Linux, there is no need to test it on Windows... ;-)

It is always good practice to receive confirmation that an issue is not present on a particular OS.
Comment 11 Don Lewis 2018-02-01 05:44:08 UTC
I'm able to confirm this issue.  I did a build on 64 bit CentOS 6.  No errors there, but if I do install on Debian 9, I see both the writer and calc errors.

I did a build with the --enable-dbgutil flag.  When opening a file with writer, no errors were reported on CentoOS 6, but I got these errors on Debian:

Error: assertion failed!
From File vcl/unx/gtk/ally/atkwrapper.cxx:874

Id -2147024824 only handled by SimpleErrorHandler
ErrorCode: 72
ErrorClass: 0
ErrorArea: 56

Error: Assertion Failed
==========================
FILE  : sw/source/core/access/acccontext.cxx at line 354
ERROR: "Vis area of child is wrong. Did it exist already?"
From File sw/source/core/except/errhdl.cxx at line 80


Then when exiting:

Error: Assertion Failed
==========================
sw/source/core/access/accmap.cxx at line 1742
ERROR: "Frame map should be empty after disposing the root frame"
From File sw/source/core/except/errhdl.cxx at line 80
 
Error: Assertion Failed
==========================
sw/source/core/attr/format.cxx at line 252
ERROR: "SwFmt::~SwFmt: Def Abhaengige!"
From File sw/source/core/except/errhdl.cxx at line 80

Error: ~swFmt: parent format missing
From File sw/source/core/attr/format.cxx at Line 259
Comment 12 Don Lewis 2018-02-01 06:22:18 UTC
ErrorCode 72 seems to come from sw/source/ui/app/error.src:

        String WARN_CODE ( ERRCODE_CLASS_READ , WARN_SWG_FEATURES_LOST )
        {
                Text [ en-US ] = "Not all attributes could be read." ;
        };

and sw/source/filter/xml/swxml.cxx:


        catch (lang::WrappedTargetException & e)
        {
            ucb::InteractiveAugmentedIOException iaioe;
            if (e.TargetException >>= iaioe)
            {
                // import error that was not ignored by InteractionHandler!
                nWarnRDF = ERR_SWG_READ_ERROR;
            }
            else
            {
                nWarnRDF = WARN_SWG_FEATURES_LOST; // uhh... something wrong?
            }
        }

I don't see any signs of a library conflict.
Comment 13 Don Lewis 2018-02-01 06:48:04 UTC
The vcl/unx/gtk/ally/atkwrapper.cxx error may be related to this
error that gets sent to stdout/stderr even with a normal build:

** (soffice:XXXX): Warning **: Unknown type: GailWindow
Comment 14 Matthias Seidel 2018-02-01 18:29:02 UTC
(In reply to Don Lewis from comment #13)
> The vcl/unx/gtk/ally/atkwrapper.cxx error may be related to this
> error that gets sent to stdout/stderr even with a normal build:
> 
> ** (soffice:XXXX): Warning **: Unknown type: GailWindow

I have seen this warning in all the latest 4.1.x versions running on Ubuntu.

I don't think it is related to this particular issue.
Comment 15 jmpoo 2018-02-09 09:53:59 UTC
I tested the Linux x86-64 deb build 4.2_de_Rev.1823225 provided by Jim Jagielski at 07.02.2017
OS Linux Mint 18.2 64bit

Error Message:
--------------
Opening an existing .odt
Opening an existing .ods

Saving a new created text document as .odt



No Error Message:
-----------------
Saving a "saved" .odt again after adding a few changes
Saving a "reopened" .odt again after adding a few changes
Saving a new created text document as .doc
Saving a new created calc document as .ods


Opening an existing .doc  (created with OpenOffice or MS Word)
Opening an existing .xls  (created with OpenOffice or MS Excel)
Comment 16 yury_t 2018-03-25 09:02:48 UTC
Am getting the error msgbox 'Error saving ... General error' on linux 64 bits.

Used the archive:

Apache_OpenOffice_4.2.0_Linux_x86-64_install-arc_en-US_2018-03-23_16_20_46_1827579.tar.gz

unpacked and set up with empty personal info (clicked 'Finish' w/o entering anything in the fields).

Reproduce for the save code path:
1) start up
2) press Ctrl+N
3) not doing anything, press Ctrl+S
4) enter the path, click save
5) msgbox, but file saved okay

Reproduce for the open code path:
1) start up
2) Ctrl+O
3) select anything, even the empty saved just a second ago
4) msgbox, but file opened okay
Comment 17 Matthias Seidel 2018-04-21 18:10:48 UTC
Confirmed on Ubuntu 16.04 32-bit, setting to "Linux, all"
Comment 18 Pedro 2018-08-11 09:22:42 UTC
I get error messages when opening odt and ods files under Ubuntu 18.04.1
This is a regression from 4.1.5
Comment 19 damjan 2018-09-23 06:24:42 UTC
(In reply to Matthias Seidel from comment #4)
> (In reply to damjan from comment #2)
> > Latest trunk built from source, works just fine on Ubuntu 16.04, 32 bit. It
> > might be the bitness, or a difference in the build options.
> 
> Can you post your build options?
> 
> The build options for the buildbots can be seen here:
> 
> https://svn.apache.org/repos/infra/infrastructure/buildbot/aegis/buildmaster/
> master1/projects/openofficeorg.conf

Significant differences from the buildbot's ./configure options:

Only on the buildbot, absent from my setup:
--with-lang="en-US de fr it pt ja"
--without-stlport
--without-junit

Present on both but different:
--with-package-format="archive rpm deb"
vs
--with-package-format="installed"

Only on my setup, absent from the buildbot:
--enable-cairo
--enable-lockdown
--enable-symbols
--enable-dbgutil
--with-system-zlib
--with-system-cairo
--with-system-nss
--with-system-jpeg
--with-system-openssl
--with-system-curl
--with-system-python
--with-system-libxml
--with-system-libxslt
--with-system-expat
--enable-coinmp
--enable-graphite
--enable-hyphen
--enable-javascript
--enable-category-b-fonts
--disable-gnome-vfs
--enable-gio
--enable-gstreamer

It could be that debugging is enabled, that system libraries are being used, that we are using different package formats, or that we are using different languages.

I am trying another build with the buildbot's flags now.
Comment 20 damjan 2018-09-23 08:29:35 UTC
Even using build flags similar to the buildbot, I still cannot reproduce this.

I built with:
./configure
--with-epm-url=https://sourceforge.net/projects/oooextras.mirror/files/epm-3.7.tar.gz
--with-dmake-url=https://sourceforge.net/projects/oooextras.mirror/files/dmake-4.12.tar.bz2
--with-lang="en-US de fr it pt ja"
--enable-wiki-publisher
--enable-verbose
--without-stlport
--enable-category-b
--enable-opengl
--enable-dbus
--without-junit
--with-package-format="installed archive deb"
--enable-bundled-dictionaries
--with-vendor=ASF buildbot - NOT FOR RELEASE --with-build-version=%(today)s-Rev.%(got_revision)s

It was started with:
unxlngi6.pro/Apache_OpenOffice/installed/install/en-US/openoffice4/program/soffice
from inside trunk/main/instsetoo_native. Both text documents and spreadsheets could be read and written without errors.


I see only the following possibilities:
* The "installed" package works, it's the DEBs that are broken. I will test that next.
* An Ubuntu package update broke something. This is a pretty old setup, without updates.
Comment 21 damjan 2018-09-23 08:41:41 UTC
(In reply to damjan from comment #20)
> Even using build flags similar to the buildbot, I still cannot reproduce
> this.

> * The "installed" package works, it's the DEBs that are broken. I will test
> that next.

Even installing DEBs and running it from there (soffice binary, command line), still works.

Maybe let me try download the binaries from the buildbot and debug them.
Comment 22 damjan 2018-09-23 08:52:42 UTC
The buildbot binaries do reproduce the problem. Is it the buildbot that is broken somehow?

The stack trace to the "General error" when loading a document is:

Thread 1 (Thread 0xb3eb8700 (LWP 5026)):
#0  0xb7735c31 in __kernel_vsyscall ()
#1  0xb723aecf in poll () at ../sysdeps/unix/syscall-template.S:84
#2  0xb30b9b60 in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb30ab11c in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb30ab254 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb343b355 in ?? () from /opt/openoffice4/program/libvclplug_gtk.so
#6  0xb33aab2b in X11SalInstance::Yield(bool, bool) () from /opt/openoffice4/program/libvclplug_gen.so
#7  0xb5fb900d in ?? () from /opt/openoffice4/program/libvcl.so
#8  0xb5fb6636 in Application::Yield(bool) () from /opt/openoffice4/program/libvcl.so
#9  0xb612a2fb in Dialog::Execute() () from /opt/openoffice4/program/libvcl.so
#10 0xb6931577 in ?? () from /opt/openoffice4/program/libsvt.so
#11 0xb645cce3 in ErrorHandler::HandleError_Impl(unsigned long, unsigned short, unsigned char, String&) () from /opt/openoffice4/program/libtl.so
#12 0xb645cd1b in ErrorHandler::HandleError_Impl(unsigned long, unsigned short, unsigned char, String&) () from /opt/openoffice4/program/libtl.so
#13 0xb645ce04 in ErrorHandler::HandleError(unsigned long, unsigned short) () from /opt/openoffice4/program/libtl.so
#14 0xab3e497a in ?? () from /opt/openoffice4/program/../program/libuui.so
#15 0xab3e71fb in ?? () from /opt/openoffice4/program/../program/libuui.so
#16 0xab3e826d in ?? () from /opt/openoffice4/program/../program/libuui.so
#17 0xab3f9c28 in ?? () from /opt/openoffice4/program/../program/libuui.so
#18 0xb6d4a329 in ?? () from /opt/openoffice4/program/libsfx.so
#19 0xb6d796e5 in SfxBaseModel::load(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) () from /opt/openoffice4/program/libsfx.so
#20 0xb6dc7abe in ?? () from /opt/openoffice4/program/libsfx.so
#21 0xaeace3ab in ?? () from /opt/openoffice4/program/../program/libfwk.so
#22 0xaeace7a8 in ?? () from /opt/openoffice4/program/../program/libfwk.so
#23 0xaea8c71f in ?? () from /opt/openoffice4/program/../program/libfwk.so
#24 0xaea8ca1b in ?? () from /opt/openoffice4/program/../program/libfwk.so
#25 0xaeb500d7 in ?? () from /opt/openoffice4/program/../program/libfwk.so
#26 0xb5fbe395 in ?? () from /opt/openoffice4/program/libvcl.so
#27 0xb619731d in ?? () from /opt/openoffice4/program/libvcl.so
#28 0xb339d5cc in ?? () from /opt/openoffice4/program/libvclplug_gen.so
#29 0xb33a608f in SalDisplay::DispatchInternalEvent() () from /opt/openoffice4/program/libvclplug_gen.so
#30 0xb343bfc8 in ?? () from /opt/openoffice4/program/libvclplug_gtk.so
#31 0xb30a7610 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0xb30aad9b in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0xb30ab189 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0xb30ab254 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0xb343b326 in ?? () from /opt/openoffice4/program/libvclplug_gtk.so
#36 0xb33aab2b in X11SalInstance::Yield(bool, bool) () from /opt/openoffice4/program/libvclplug_gen.so
#37 0xb5fb900d in ?? () from /opt/openoffice4/program/libvcl.so
#38 0xb5fb6636 in Application::Yield(bool) () from /opt/openoffice4/program/libvcl.so
#39 0xb5fb666e in Application::Execute() () from /opt/openoffice4/program/libvcl.so
#40 0xb753321c in ?? () from /opt/openoffice4/program/libsofficeapp.so
#41 0xb5fbc269 in ?? () from /opt/openoffice4/program/libvcl.so
#42 0xb5fbc3e8 in SVMain() () from /opt/openoffice4/program/libvcl.so
#43 0xb7549b39 in soffice_main () from /opt/openoffice4/program/libsofficeapp.so
#44 0x08048c40 in main ()


Similar story with "Save As":

Thread 1 (Thread 0xb3eb8700 (LWP 5026)):
#0  0xb7735c31 in __kernel_vsyscall ()
#1  0xb723aecf in poll () at ../sysdeps/unix/syscall-template.S:84
#2  0xb30b9b60 in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb30ab11c in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb30ab254 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb343b355 in ?? () from /opt/openoffice4/program/libvclplug_gtk.so
#6  0xb33aab2b in X11SalInstance::Yield(bool, bool) () from /opt/openoffice4/program/libvclplug_gen.so
#7  0xb5fb900d in ?? () from /opt/openoffice4/program/libvcl.so
#8  0xb5fb6636 in Application::Yield(bool) () from /opt/openoffice4/program/libvcl.so
#9  0xb612a2fb in Dialog::Execute() () from /opt/openoffice4/program/libvcl.so
#10 0xb6931577 in ?? () from /opt/openoffice4/program/libsvt.so
#11 0xb645cce3 in ErrorHandler::HandleError_Impl(unsigned long, unsigned short, unsigned char, String&) () from /opt/openoffice4/program/libtl.so
#12 0xb645cd1b in ErrorHandler::HandleError_Impl(unsigned long, unsigned short, unsigned char, String&) () from /opt/openoffice4/program/libtl.so
#13 0xb645ce04 in ErrorHandler::HandleError(unsigned long, unsigned short) () from /opt/openoffice4/program/libtl.so
#14 0xab3e497a in ?? () from /opt/openoffice4/program/../program/libuui.so
#15 0xab3e71fb in ?? () from /opt/openoffice4/program/../program/libuui.so
#16 0xab3e826d in ?? () from /opt/openoffice4/program/../program/libuui.so
#17 0xab3f9c28 in ?? () from /opt/openoffice4/program/../program/libuui.so
#18 0xb6d0687d in SfxMedium::CallApproveHandler(com::sun::star::uno::Reference<com::sun::star::task::XInteractionHandler> const&, com::sun::star::uno::Any, unsigned char) () from /opt/openoffice4/program/libsfx.so
#19 0xb6d7f023 in ?? () from /opt/openoffice4/program/libsfx.so
#20 0xb6d7f636 in SfxBaseModel::storeAsURL(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) () from /opt/openoffice4/program/libsfx.so
#21 0xb6d3a6a3 in ?? () from /opt/openoffice4/program/libsfx.so
#22 0xb6d4f13f in ?? () from /opt/openoffice4/program/libsfx.so
#23 0xb6c8ef2e in ?? () from /opt/openoffice4/program/libsfx.so
#24 0xb6c88345 in ?? () from /opt/openoffice4/program/libsfx.so
#25 0xb6c899c9 in SfxDispatcher::_Execute(SfxShell&, SfxSlot const&, SfxRequest&, unsigned short) () from /opt/openoffice4/program/libsfx.so
...
Comment 23 damjan 2018-09-23 09:16:36 UTC
It is difficult what went wrong, when this isn't a debug build, but disassembling from frame #18 in the "Save As" stack trace:

   0xb6d0686f <+315>:	call   0xb6c18ee0 <_ZN9framework18InteractionRequest13CreateRequestERKN3com3sun4star3uno3AnyENS4_8SequenceINS4_9ReferenceINS3_4task24XInteractionContinuationEEEEE@plt>
   0xb6d06874 <+320>:	mov    -0x30(%ebp),%ecx
   0xb6d06877 <+323>:	mov    %esi,(%esp)
   0xb6d0687a <+326>:	push   %edi
   0xb6d0687b <+327>:	call   *%ecx
=> 0xb6d0687d <+329>:	mov    %esi,(%esp)
   0xb6d06880 <+332>:	call   0xb6cbc456

The manged C++ symbol demangles to framework::InteractionRequest::CreateRequest(com::sun::star::uno::Any const&, com::sun::star::uno::Sequence<com::sun::star::uno::Reference<com::sun::star::task::XInteractionContinuation> >)

which is from main/sfx2/source/doc/docfile.cxx:

sal_Bool SfxMedium::CallApproveHandler( const uno::Reference< task::XInteractionHandler >& xHandler, uno::Any aRequest, sal_Bool bAllowAbort )
{
    sal_Bool bResult = sal_False;

    if ( xHandler.is() )
    {
        try
        {
            uno::Sequence< uno::Reference< task::XInteractionContinuation > > aContinuations( bAllowAbort ? 2 : 1 );

            ::rtl::Reference< ::comphelper::OInteractionApprove > pApprove( new ::comphelper::OInteractionApprove );
            aContinuations[ 0 ] = pApprove.get();

            if ( bAllowAbort )
            {
                ::rtl::Reference< ::comphelper::OInteractionAbort > pAbort( new ::comphelper::OInteractionAbort );
                aContinuations[ 1 ] = pAbort.get();
            }

            xHandler->handle(::framework::InteractionRequest::CreateRequest (aRequest,aContinuations));
            bResult = pApprove->wasSelected();
        }
        catch( const Exception& )
        {
        }
    }

    return bResult;
}


I still can't really tell where it goes wrong though. Can we get a debug build from the buildbot?
Comment 24 Matthias Seidel 2018-09-23 09:31:46 UTC
(In reply to damjan from comment #23)
...
> I still can't really tell where it goes wrong though. Can we get a debug
> build from the buildbot?

Maybe we can get a debug build from Jim after he returns from ApacheCon.

He made a build on CentOS with release options and the problem still occurred.
Comment 25 Mechtilde 2019-01-17 10:07:28 UTC
I tested it with an own build of r1851103. 

there it works as expected. So I set it as fixed
Comment 26 yury_t 2019-01-17 10:53:20 UTC
Actually, this isn't 'fixed' at all. Nightly builds still produce the error msgboxes. Just tested with Apache_OpenOffice_4.5.0_Linux_x86-64_install-arc_en-US_2019-01-15_13_12_01_1851345.tar.gz
Comment 27 yury_t 2019-01-17 10:54:00 UTC
My own local build also doesn't have this issue, but the official nightly builds do.
Comment 28 jolatt 2019-01-18 14:37:13 UTC
IMO this shouldn't be changed based on local builds.
Comment 29 jolatt 2019-01-18 14:57:44 UTC
(In reply to jolatt from comment #28)
> IMO this shouldn't be changed based on local builds.

May be 'local builds' isn't the right wording, 'own builds' sounds better.
Comment 30 Mechtilde 2019-01-19 07:08:50 UTC
please test with the nightly builds from 12019-01-17 12:34:58
Comment 31 yury_t 2019-01-19 09:26:51 UTC
The issue's still there in 

Apache_OpenOffice_4.2.0_Linux_x86-64_install-rpm_en-US_2019-01-17_16_55_24_1851547.tar.gz,

with clean profile, too.

The 4.5.0 one aborts, as I've reported on IRC.
Comment 32 yury_t 2019-01-19 15:57:32 UTC
Issue's still there in:

Apache_OpenOffice_4.5.0_Linux_x86-64_install-arc_en-US_2019-01-19_09_12_11_1851663.tar.gz

And thanks for looking into the trunk problems today, guys.
Comment 33 Peter 2019-02-10 20:07:44 UTC
Is this issue now fixed or not. I am confused.
Comment 34 Pedro 2019-02-11 15:12:29 UTC
(In reply to Peter from comment #33)
> Is this issue now fixed or not. I am confused.

No issues under Ubuntu 18.04.1 using the latest DEB package from Jim Jagielski
AOO420m1(Build:9800)  -  Rev. 1851640
2019-01-19 15:48:21 (Sat, 19 Jan 2019) - Linux x86_64 [Apache OpenOffice Test Development Build]

@yuri_t please test with Jim's latest build (same settings as official releases)

http://people.apache.org/~jim/AOO-builds/

Unfortunately builds from the nightly buildbots are not on the same quality level ;)
Comment 35 yury_t 2019-02-11 19:08:32 UTC
Standard development builds for 420 and 450 both have the issue:

AOO420m1(Build:9820)  -  Rev. 1853177
2019-02-10_09:51:39 - Rev. 1853301

AOO450m1(Build:9900)  -  Rev. 1853099
2019-02-07_11:09:43 - Rev. 1853118

'Jim's build' for 420 works okay:

AOO420m1(Build:9800)  -  Rev. 1851640
2019-01-19 15:48:21 (Sat, 19 Jan 2019) - Linux x86_64 [Apache OpenOffice Test Development Build]
Comment 36 jolatt 2019-03-29 07:29:19 UTC
No issues.

AOO420m1(Build:9820)  -  Rev. 1856382
2019-03-27 11:20:27 (Wed, 27 Mar 2019) - Linux x86_64 [Apache OpenOffice Test Development Build]

Ubuntu 18.10 64bit